Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When rebooting the sequence freezes at the very last stage in which it attempts to the the system to reset through ACPI.

Setting acpi=off in grub.cfg fixed this problem, but I was unable to suspend, which was the greater evil.

Shutdown and Suspend work fine with ACPI enabled.

How can I get this fixed without disabling ACPI (or without being unable to suspend)?

share|improve this question
    
I'm not sure what your saying. However I too have a dell M4600 and have problems coming back from a suspend. My file system gets corrupted. Is this happening to you? Try reboot into recovery mode see if you need to run fsck. –  Nicholas Marshall Mar 18 '12 at 18:00
    
My original problem is not coming back from suspend, but doing a reboot. Turning ACPI to off, fixed reboot problem but breaks suspend. (instead of suspending it simply locks the screen). I do not get file-system corruptions. –  d_inevitable Mar 18 '12 at 18:02
    
Could you try noapic instead of acpi=off and see if you experience different symptoms? I only ask because I found this thread on a Dell mailing list searching around for you: lists.us.dell.com/pipermail/linux-precision/2011-July/… –  Jayson Rowe Mar 23 '12 at 2:19
    
@JaysonRowe noapic did work and you were the first to suggest it. Therefore I think you deserve the bounty most. Please convert it into an answer so that that I can assign you the bounty. Otherwise I will give it to fossfreedom who also suggested noapic –  d_inevitable Mar 25 '12 at 9:52
    
Are you using both now, noapic and acpi=off? I've tried with noapic, and most of the times I can suspend (failed once yesterday evening). But I'm not able to reboot or shutdown (just hangs and I've to hold button for 5 seconds). Can you maybe send your complete grub config from /etc/default? FYI: Running Dell precision M4600, ubuntu 11.10 –  user53711 Apr 6 '12 at 7:23

4 Answers 4

up vote 2 down vote accepted

Try adding reboot=pci to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub, then running update-grub. This worked on my m4600.

share|improve this answer
    
This worked for me for some time for my m4600, but now with this option, instead of rebooting it just shuts down. Still better than freeze, but this is not the expected behaviour of reboot. (Ubuntu 14.04 now). –  Piotr Kolaczkowski Aug 8 at 7:20

Could you try noapic instead of acpi=off and see if you experience different symptoms? I only ask because I found this thread on a Dell mailing list searching around for you: http://lists.us.dell.com/pipermail/linux-precision/2011-July/001515.html

share|improve this answer

Adding reboot=pci to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub, then running update-grub worked perfectly for me on my m4600.

share|improve this answer

Switching off acpi indicates either power-management issues or IRQ conflicts.

This sometimes can be resolved by flashing your BIOS with the latest BIOS firmware available from your motherboard manufacturer.

Note - flashing a BIOS should always be done in accordance with the manufacturers recommendations - usually only from MS Windows.

There are a number of grub boot options you can try as per the community wiki:

https://help.ubuntu.com/community/BootOptions

The solution I found to to a similar issue was to add to grub the noapic or the nolapic grub boot parameter.

When testing grub boot option you could use my answer here to temporarily add the kernel options at boot time.

How to set nomodeset for installation?

share|improve this answer
    
Setting it to noapic did work, thank you. However @JaysonRowe has suggested noapic first inside a comment, so I think he really deserves the bounty. I have upvoted your answer though. –  d_inevitable Mar 25 '12 at 9:55
    
@d_inevitable - no worries - I didnt see Jayson's comment - otherwise I wouldnt have posted the answer. Thanks for the +1. –  fossfreedom Mar 25 '12 at 10:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.