Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My computer is unable to suspend/hibernate on Ubuntu 11.10. Some people told me that probable had to do with my bios setting, that I should set my ACPI settings to S3.

The problem is that I can't find that S3 thing anywhere. I have an Asus p8p67 LE motherboard.

The only thing I think could be related is this on "advanced->APM:

  • Power on my PS/2 Keyboard : Disabled
  • Power on my PS/2 Mouse : Disabled
  • Restore AC Power Loss : Power Off
  • Power on my PCI : Disabled
  • Power on my PCIE : Disabled
  • Power on my Ring : Disabled
  • Power on my RTC : Disabled

Can I get suspend with that? How should I configure it?

EDIT: I explained in detail my problems in this other question (which was closed) Fail to wake up after suspend, buggy after hibernate

share|improve this question
    
did you look at the UEFI BIOS - EZ Mode - Flexible & Easy BIOS Interface –  Ringtail Mar 10 '12 at 15:43
    
No, I'm going to check it. –  Cmorales Mar 10 '12 at 15:49
2  
Post #7 looks interesting here - any of this helps? bbs.archlinux.org/viewtopic.php?id=117643 –  fossfreedom Mar 12 '12 at 23:47
1  
@Cmorales - you can download 3.2.1 from here (kernel.ubuntu.com/~kernel-ppa/mainline/v3.2.1-precise) - image your computer first before playing with kernels and patching just incase you get a no-booting situation. Hope this helps. –  fossfreedom Mar 16 '12 at 10:16
1  
I have downloaded and I get into troubles with the nvidia and virtualbox drivers (which is something usual, from what I read). In addition I couldn't test if the patch worked because I tried following the instructions in the post but got some errors. I think I'll give up and will try to fix it in 12.04, I don't have by any means the knowledge to do it by myself now. Anyway, @fossfreedom, should post your comment as an answer and I'll give the bounty to you, since I think it's the most relevant. –  Cmorales Mar 16 '12 at 21:56

3 Answers 3

up vote 2 down vote accepted
+50

your issue

This link mentions your motherboard and an issue that is similar if not the same as yours.

It goes on to mention that a patched v3.2.1 kernel can resolve your issue. Obviously, v3.2.1 is not the kernel in Oneiric.

backup!

Yes - backup! Changing your kernel can cause black screen and non-booting scenarios. Backup with a good image tool such as Clonezilla

installing pre-built kernels

The usual recommendation is to download the latest ubuntu kernel built with the ubuntu tool-chain - i.e. the v3.2 kernel in precise and try and install that.

You could also try the vanilla kernels built directly from the kernel mainline.

compiling your own kernel

If these kernels do not resolve this, then you will need to compile your own kernel.

Use the link below to download the 3.2 kernel source and patch it with the ubuntu kernel config.

Then use these instructions to patch your newly downloaded source with some ACPI changes.

Finally, use the remaining instructions in the link below to build your source.


Link Question:

  1. How to build the mainline kernel source package?
share|improve this answer

Normal BIOS settings

S0 (Working) is lit. The CPU functions in entirety; the conservation of power is on a basis of by-device.

S1 (Sleep). The CPU is stopped; The RAM is regenerated; the system functions in reduced power.

S2 (Sleep 2) The CPU does not have any power; The RAM is regenerated; the system is in lower mode of the S1.

S3 (Standby) The CPU does not have any power; The RAM regenerates at minimum; the power supply unit is in mode of reduced power. This mode is also called “Save to RAM”.

S4 (Hibernate). All is powered off, but the memory was saved like temporary file on the hard drive. This mode is called “Save to disk”.

S5 (Off) Everything is shutdown. Means you need a full reboot.

S3 is the best. It uses less power and reboots faster.

  • However, "I have an Asus P8P67-M Pro motherboard which fails to suspend to ram under Linux yet suspends successfully under Windows 7". read the article

I may not be a possibility at this point

share|improve this answer
    
As I explain in the original post, I can't find anything related to that S(x) in the BIOS settings. The article you link is interesting, I have to try updating the BIOS (though I am not sure how). –  Cmorales Mar 14 '12 at 15:26

Have your bios updated, read the instructions carefully and update the bios, (as I said read the full instructions about the update, if it doesn't provide S3 support, give up)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.