Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to reset Unity. But when I type unity --reset I get the following error:

Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Compiz (opengl) - Fatal: glXCreateContext failed
Compiz (bailer) - Info: Ensuring a shell for your session

... I am not using Compiz! I am using Metacity.

Thanks a lot :)

EDIT:

I am using Unity. And I want to reset it as the sidebar is always shown when I am viewing my desktop (although it hides automatically if I am using other applications) and Alt+Tab switches the windows in a different, poor way (not the default one of Ubuntu 11.10).

share|improve this question
add comment

1 Answer 1

Which Graphics card do you have?

Is ubuntu prompting you to install any restricted drivers? If yes, install them.

EDIT: If not check again by running jockey-gtk. Activate your graphics driver there.

According to unity --help, unity --reset is specific to compiz:

--reset Reset the unity profile in compiz and restart it.

So if you are just using unity 2d, then try resetting the profile by deleting the configuration file, but I only found how to reset all configurations for your user:

Can I reset Unity 2D?

But I think that you do not have to reset it all, just try:

dconf reset -f /desktop/unity/

I couldn't find any other unity entries in dconf. If it doesn't solve your problem, use dconf-editor to find any other entries in there.

Edit:

I have also found some unity-2d related settings in gconf under /desktop/unity-2d. I do not know how to reset these though, so post my value, which should be default as I am not using unity:

/desktop/unity-2d/launcher/favorites:

[ubiquity-gtkui.desktop,nautilus-home.desktop,firefox.desktop,libreoffice-writer.desktop,libreoffice-calc.desktop,libreoffice-impress.desktop,ubuntu-software-center.desktop,ubuntuone-control-panel-gtk.desktop]

/desktop/unity-2d/launcher/hide_mode: 2

/desktop/unity-2d/launcher/super_key_enable: yes

/desktop/unity-2d/launcher/user_strut: no

You haven't specified why you want to reset unity, but these gconf settings will only reset the favourite icons on the unity launcher and make unity hide when it is not active and trigger something on the super (windows) key.

share|improve this answer
    
Thanks a lot :) but I am using Unity (not Unity-2D). And I wan't to reset it because the sidebar is always shown when i am viewing my desktop (Although it hides automatically if i am opening other applications) –  Elshaer Mar 10 '12 at 14:13
    
@Elshaer Unity (not Unity-2d) without compiz is impossible afaik. So if you are not using compiz, then you are using unity-2d or something extremely dodgy. :) –  d_inevitable Mar 10 '12 at 14:20
    
@Elshaer setting /desktop/unity-2d/launcher/hide_mode to 2 in gconf-editor should solve your problem unless your not happy with the default setting either. –  d_inevitable Mar 10 '12 at 14:34
    
mmmm ... then I am using unity-2d :) Thanks, I found that /desktop/unity-2d/launcher/hide_mode was already set to 2 !! –  Elshaer Mar 10 '12 at 14:51
    
One more thing if i type "compiz --replace" it get "Compiz (opengl) - Fatal: glXCreateContext failed" –  Elshaer Mar 10 '12 at 14:51
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.