Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My network driver drops out within a short time of logging on. The situation is explained more readily in the following forums thread which has not been replied to as yet. As I am not very computer literate, I would appreciate guidance about correctly installing the driver or alternatively point me in the right direction to assist me in providing a solution.

I have looked at a number of posts in launchpad however these tend to confuse me. I hope that somebody is able to help me - thank you

share|improve this question

The problem is more likely that you need to install a different driver. My system defaults to using r8169 and I can never get stable connections with it (except on newer kernel versions than Ubuntu is using).

If your Ethernet chip set is RTL8111/8168B, I recommend that you download and install driver r8168. The version you need to find is 8.028 or greater.

After you expand the driver into its own directory, cd into that directory and run "sudo ./". After that script completes, your ethernet connection should start, and it should also be stable.

You will have to reinstall the driver every time you upgrade to a newer Linux kernel. At least until Linux gets to the level where r8169 starts working.

share|improve this answer
Thank you for your prompt answer Tim - That may well be the road I will have to take - In the meantime I have come up with a possible Windows solution which is outlined in the third post of the Ubuntu thread. It has been working for 8 hours without a hitch. I am keeping my fingers crossed. – Geoff Smith Mar 11 '12 at 2:38

I've just upgraded my machine & the new motherboard has this chipset network on board. I've had exactly this issue & have discovered that everything works ok as long as the machine is cold booted into Ubuntu. If the system has been running windows 7 first then the network stops responding a few minutes after boot.

share|improve this answer
Thanks Jon - For me problem remained regardless of which system I booted into first. For now I have obtained a fix by making adjustments in Windows as outlined in post 3 of Ubuntu thread. Until I am forced to seek another solution this will do me for now - has been working O.K. for a number of weeks. Will mark as solved. – Geoff Smith Mar 21 '12 at 23:42
up vote -1 down vote accepted

Until I am forced to obtain another solution I will rely on the "Windows" solution I have obtained which has worked satisfactorily now for a number of weeks - Thanks to all for help.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.