Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have both RecordMyDesktop and XVidCap installed. I also have OpenShot and Pitivi installed. OpenShot crashes more than Pitivi, and has more features, but Pitivi has a far better interface. But the lack of features means that I have to deal with OpenShot's unreliability.

If I capture my desktop with RecordMyDesktop, then the resulting video plays fine in the video player. However, once imported into OpenShot, the video is pixelated (even when rendered as an exported video). Ironically, when importing the same captured video into Pitivi, everything works well and as it should.

If I capture my desktop with XVidCap (which isn't as friendly as RecordMyDesktop), then everything works fine in OpenShot (and Pitivi).

What I do know is that RecordMyDesktop saves files as OGG while XVidCap saves files as MPEG. But should that make a difference when using OpenShot and Pitivi? (I have all the restricted extras and Gstreamer stuff installed, for example.)

RecordMyDesktop (and OGG files) are preferable to XVidCap. Any idea what's going on here?

EDIT: Correction. RecordMyDesktop seems to create OGV files.

share|improve this question
    
Can you get the output from "mediainfo*" after saving each import? Sounds like one of them is messing with the fps or compression on import. *you may need to apt-get mediainfo. –  Meddy Mar 10 '12 at 8:42

1 Answer 1

up vote 0 down vote accepted

Same here.

Pitivi and Totem uses gstream and work fine with RecordMyDesktop OGV files.

OpenShot, mplayer, mplayer2, smplayer, mencoder and ffmpeg show the video "pixelated"

mplayer says:

==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [fftheora] vfm: ffmpeg (FFmpeg Theora)
==========================================================================

I fixed it using VLC to convert RecordMyDesktop OGV files to WEBM, then opening in OpenShot.

share|improve this answer
1  
While not ideal, this worked for me too. Thanks. I'll do things this way until it's eventually fixed (or when I try a new Ubuntu distribution). –  Gonzoza Apr 7 '12 at 16:34
    
Fixed in Ubuntu 12.04 –  Nilzao May 7 '12 at 19:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.