Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am not sure how this is even possible. Looking at top, my loads are often above 2, 3, 4.0, but I am over 99% idle. There is never a process at the top that is taking up anything, all my processes are 0. This is a new-ish i-5 laptop that was running very fast in 10.04, but is almost un-usable in 10.10. Does anyone have any ideas? How is the load so high with nothing running?

Thanks

share|improve this question
    
I face that very problem frequently. CPU hogging is main problem for me –  user Apr 20 '11 at 17:36

4 Answers 4

up vote 4 down vote accepted

It's usually a result of a driver running within the kernel. These threads don't usually show up in top and even with kernel threads showing, sometimes they don't show. I've been in your situation. There wasn't a way to show the precise cause but upgrading my graphics driver fixed the issue.

I fear the precise problem in your case is probably a regression in the kernel's drivers. My money would be on graphics.

Dislaimer: What I'm about to suggest could break things. It's unlikely but possible. If you're not happy with the command line, or don't know how to get into a LiveCD environment to fix things, I would stop reading here, just in case.

You can fall back to an older kernel (and therefore drivers) by installing the mainline packages. There isn't a simple apt-get for this as older kernel versions aren't built for Maverick. But you can get the mainline .deb files from here:

http://kernel.ubuntu.com/~kernel-ppa/mainline/

You'll probably want 2.6.32.25-lucid but you could also try 2.6.36 to see if it has been fixed in later versions.

To test you'll need the packages for your architecture (see uname -a) and the -all package. Stick them in a directory with nothing else, cd in and run dpkg -i *.deb. You can double-click them to install but you have to do them in the right order or it'll fail.

When installed you'll need to reboot and before Ubuntu starts to load, you'll need to hold the left shift key. This will force the GRUB bootloader to show and you can select which kernel you use.

However if the older (formerly working) version doesn't work, it's a problem elsewhere.

share|improve this answer
    
I think you are probably on the right track, I think it may be an issue with the kernel or some kernel modules. I have already tried 2.6.36-rc8 from that page with no difference. I have already uninstalled all fgrlx drivers, compiz, and the like to no joy either. I think I will try your suggestion, and try an older lucid kernel... argh, sounds like a mess... –  user5292 Nov 3 '10 at 14:19
    
@Landon There might be issues with an old kernel and a new X. But the strange thing is, I would expect other people to have this issue too... At least for it to be searchable. What is your laptop make/model? –  Oli Nov 3 '10 at 14:21
    
Yes, I found it strange too, as the first thing I did was search Google... The laptop is an HP Envy 15t, core i-5 with Radeon 4200 graphics. This thing worked beautifully in 10.04 and I never should have upgraded... –  user5292 Nov 3 '10 at 14:27
    
Any luck with an older ~.32 kernel? –  Oli Nov 3 '10 at 16:10
    
Well, I thought that worked, after the boot-up, it dropped to sub 0.5, the first time that's happened in 10.10. But, then it started to rise steadily, and within 3 minutes was up to over 3.0 again with idle CPU usage... I am thinking I may have to just do a fresh install of 10.04, thanks for the help! –  user5292 Nov 3 '10 at 19:49

System load is totally different from cpu load. System load counts the average number of processes that are in a waiting state. They might not necessarily waiting for the cpu, but maybe for some i/o that is blocked (network, disks, swapping, etc.).

See also http://en.wikipedia.org/wiki/Load_(computing)

share|improve this answer

Maybe overheating? When my computer overheats (this problem was with ubuntu 08.04), then it is lagging and CPU is 80-100%.

share|improve this answer
    
I don't think it's over-heating, the problem is there from a cold boot up and the fans kick on okay and everything, but the load goes high shortly after bootup and just stays there. CPU usage is always around 0 (99.5+% idle), but the load has not dropped below 1.0 since I upgraded... –  user5292 Nov 3 '10 at 14:07

If your laptop's fan is constantly on high then it is likely that dust is blocking the vents of laptop which is interfering with cooling and causing your laptop to overheat. You should check out your CPU and GPU temperatures to see if anything is abnormally high.

If you are experiencing a slow down in performance it's an indication that the CPU is being slowed down, which is usually done when a computer is getting too hot.

Let us know what your laptop temperatures are.

share|improve this answer
1  
CPU temp right now is 42-43 C, which is higher than it should be, and higher than it was in 10.04. The fan is running pretty high as well. I don't think it's something blocking the fan as this was not a problem in 10.04, but has been a consistent problem since day 1 of the upgrade. –  user5292 Nov 3 '10 at 14:10
    
I guess this could be a chicken and egg problem: which came first, the high CPU load, or the high temp? :) –  user5292 Nov 3 '10 at 14:11
    
43C doesn't sound too bad. Certainly not at the point where the CPU would be scaling to cut down heat. On my desktop (with good cooling) I'm at 54C. –  Oli Nov 3 '10 at 14:15
    
I think 42-43 Celsius is not too high. My computer is allways something like 40-50 C. Over 60 is high. –  Medieval Nov 3 '10 at 14:17
    
Okay, thanks, that is good to know. I think it was around 32 C in 10.04... –  user5292 Nov 3 '10 at 14:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.