Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My wireless works fine when it IS enabled. But it needs to be enabled at every startup, rather than just being automatically enabled from the beginning of the session. I'm running a Lenovo X121e, and have installed Xubuntu 11.10 onto it.

Any ideas on how to make it so it starts as enabled automatically?

share|improve this question
    
which hardware do you have? Could you paste the output of lshw -c network ? –  sagarchalise Mar 10 '12 at 6:53
1  
Did you add the Network Manager to the startup applications list? You should see a checked item called "Network". –  Chan-Ho Suh Mar 10 '12 at 6:59
    
Yup, it's on. If I have the Ethernet cable in, it's fine. At start up, Networking is enabled, but not Wireless. –  Pepe Lebuntu Mar 11 '12 at 7:14

2 Answers 2

This is probably you did a hardware switch. This can be undone by pressing your wifi activator key. It differs on different computers. But to check, open your terminal crlt+alt+t. Then press rfkill list (Description of rfkill: rfkill - tool for enabling and disabling wireless devices). It will show weather or not your wifi and LAN is either hard blocked or soft blocked. Hard blocked is when the wifi (for example) is blocked by a physical button/switch. Soft block is when it was blocked virtualy though the OS. Before you try and reboot and press the wireless button to activate it, try using the following command: rfkill unblock wifi then check if it is blocked. Use rfkill list to check if its block on unblocked afterwards. If it is hard blocked, just reboot and press the wireless botton.

share|improve this answer
    
Thanks for that: it says: 0: tpacpi_wwan_sw: Wireless WAN Soft blocked: yes Hard blocked: yes 1: phy0: Wireless LAN Soft blocked: no Hard blocked: no So does this mean I need to unblock my wireless WAN? If so, how? –  Pepe Lebuntu Mar 22 '12 at 2:12
    
So just reboot and press your enable/disable wireless button as it boots up in ubuntu. It should work then. –  jaorizabal Mar 22 '12 at 11:21

For me it is a bug. I filled a report here https://bugs.launchpad.net/ubuntu/+source/linux/+bug/951810

Further update:

The problem is the bios as this bug https://bugs.launchpad.net/ubuntu/+source/linux/+bug/812866 updating the bios, then reset to default the bios solve this issue

share|improve this answer
1  
Thanks. I've added myself to the bug report's "I'm effected by the problem". So it USED to work fine for you, but now it doesn't? –  Pepe Lebuntu Mar 11 '12 at 7:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.