Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to setup my Ubuntu 10.04 Server to allow PXE booting for the clients in my lab. I have configured the DHCP settings and everything, and I boot up my client, and it sits at a screen similar to the following:

CLIENT MAC ADDR: 00 01 80 5F 9A 79  GUID: 00000000 0000 0000 0000 000000000001
CLIENT IP: 192.168.0.128  MASK: 255.255.255.0  DHCP IP: 192.168.0.100
GATEWAY IP: 192.168.0.100
_

Before, I was getting the wonderful "PXE- T01 File not found" error, but now it just stalls. I checked the syslog on my server, and it gives me the following info:

dhcpd: DHCPDISCOVER from 00:01:80:5f:9a:79 via eth1
dhcpd: DHCPOFFER on 192.168.0.128 to 00:01:80:5f:9a:79 via eth1
dhcpd: DHCPREQUEST for 192.168.0.128 (192.168.0.100) from 00:01:80:5f:9a:79 via eth1
dhcpd: DHCPACK on 192.168.0.128 to 00:01:80:5f:9a:79 via eth1
in.tftpd[2371]: tftp: client does not accept options

Not quite sure what is going on here. I looked up the whole "client does not accept options", however most places I find say to ignore it. I still have the problem of stalling, however.

Here is my dhcpd.conf file:

ddns-update-style none;
authoritative;
allow booting;
allow bootp;

option domain-name-servers 208.67.222.222, 208.67.220.220;

default-lease-time 600;
max-lease-time 7200;

log-facility local7;

subnet 192.168.0.0 netmask 255.255.255.0 {
    range 192.168.0.1 192.168.0.254
    option domain-name-servers 208.67.222.222;
    option routers 192.168.0.100;
    option broadcast-address 192.168.0.255;
    option subnet-mask 255.255.255.0;

    default-lease-time 600;
    max-lease-time 7200;

    next-server 192.168.0.100;
    filename "pxelinux.0";
}

I have been using this tutorial, by the way:

http://www.serenux.com/2010/05/howto-setup-your-own-pxe-boot-server-using-ubuntu-server/

If there is anymore information I can provide that could be of assistance, please inform me and I will provide it.

Thank you in advance for all of your help

share|improve this question
    
Firewall disabled? Please post cat /var/log/messages | grep dhcpd –  Meddy Mar 10 '12 at 9:02
    
It'll take a few days. We are on Spring Break and the building's power is being shut off for a day. Once it is back on I will have my professor turn the server back on and check it out. –  Alex Brooks Mar 12 '12 at 0:59
    
Sorry for the large delay in response. Here is one of the results from the file: dhcpd: DHCPDISCOVER from 00:01:80:5f:9a:79 from eth1 dhcpd: DHCPOFFER on 192.168.0.128 to 00:01:80:5f:9a:79 via eth1 dhcpd: DHCPREQUEST for 192.168.0.128 (192.168.0.100) from 00:01:80:5f:9a:79 via eth1 dhcpd: DHCPACK on 192.168.0.128 to 00:01:80:5f:9a:79 via eth1 –  Alex Brooks Mar 19 '12 at 0:16
    
@Meddy Does this information help? Does anyone have any ideas how to fix this issue? –  Alex Brooks Mar 23 '12 at 15:08

1 Answer 1

up vote 2 down vote accepted

Found the problem: The pxelinux.0 file did not copy over correctly. There must have been an error when I was downloading the CD, as when I looked through all of the files, the pxelinux.0 file was empty.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.