Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I see the following being queried all over. But don't see any answers or did I miss them ? Seems to be a strange use of language. Something wicked happened. Is this a form of malware ? How do I get the Update Manager to move on ?

W: Failed to fetch
  Something wicked happened resolving '' (-5 - No address associated with hostname)
share|improve this question
It looks like your DNS is being messed up, please switch to another mirror and try again -… – James Mar 9 '12 at 21:57

It seems its a DNS resolve problem..

To solve this edit your /etc/resolv.conf (sudo nano /etc/resolv.conf) and add the google public DNS addresses like this:.


Do the ping test again on a known server and if that passes do a apt-get update..

Hope this helps, if not say so, gl. ;)

share|improve this answer
no this did not work unfortunately. the only contents in my resolv.conf file are the two nameserver entries listed above. the other commands i mentioned above still return same values – cduggan Sep 29 '11 at 17:20
also my /etc/network/interfaces only has the following entries.... auto lo , iface lo inet loopback – cduggan Sep 29 '11 at 17:36
Well, your network connection is down: try "ifconfig auto up" to see if the network goes up automatic and do "ifconfig -a" to see any changes on your network interfaces. You can also assign the addresses manually, have a look at the ifconfig here: or by doing man ifconfig. – Bruno Pereira Sep 30 '11 at 9:21
I had two ethernet connections defined, one for the normal local network, one for logging into and configuring a special router. When logged into that router, there is no connection to the normal network. It turned out that Ubuntu had switched the connections somehow. – SPRBRN Aug 1 '13 at 7:39
@BrunoPereira, ifconfig is deprecated. Use the command ip addr. See – SPRBRN Aug 1 '13 at 7:41

I know this may not address your problem, but I had this problem and it was because I had added a domain only accessible through VPN to my /etc/apt/apt.conf.d/01proxy file. I commented out the line and it worked.

I wanted to share just to show where other errors might originate from.

share|improve this answer

I have had the same issue myself, usually it occurs when there is a lot of high usage on my home network and update manager has a hard time contacting the server.

Try again after a few minutes and I think you will find it will be resolved.

share|improve this answer
It worked. Many Thanks. – Tony Hall Mar 10 '12 at 6:24
@TonyHall if the answer solved your problem can you accept it and upvote (if you want) – Mark Rooney Mar 10 '12 at 22:56

I had this problem for about 2 days. Finally, I switched my ADSL router off and back on. That fixed it for me.

share|improve this answer

the failsafe solution is to change your software sources in ubuntu (either ubuntu software center OR synaptics, depending on how recent your ubuntu is).

you seem to using the ZA (south africa) servers. change to MAIN SERVER.

in 12.04 and 12.10:

UbuntuSOftwareCenter > EDIT > SOFTWARE SOURCES


this is very common in local ubuntu repositories, like south africa and brazil.

share|improve this answer
This worked. Thanks. – jsp99 Sep 12 '13 at 10:21

The only thing that worked for me was setting the proxy setting in Apt config. Adding it to bashrc did not work.

See :

share|improve this answer

I followed your instructions and read the possibilities of this page. None of them solved my problem - so I searched again...

While I had the problem that the hostnames aren't reachable I saw, that something like a IPv6 address is in brackets.

Remembering problems between ipv4 and ipv6 i switched off ipv6 on my routers web interface - and now: the address is reachable after a few seconds.

Don't know how to disable ipv6 in ubuntu or if your router can disable this feature, too - but in my case it was the solution. Not to forget: just replug the cable before trying again, because of the ipv6 lease you already got!

share|improve this answer
Welcome to AskUbuntu! This does not appear to be an answer to the question. – No Time Aug 27 '14 at 2:31

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.