Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 11.10 with Gnome-shell 3.2, and i may have done something wrong (probably with dconf or gconf).

But now pressing F2 within nautilus opens a terminal, and Shift+F2 do the rename stuff (but selecting all filename including extension).

How can I can revert back to default behavior ? Thanks in advance.

share|improve this question
add comment

1 Answer 1

Under the "System Settings application > Keyboard > Shortcuts > Launchers" you can set the shortcut to launch Terminal. I guess there is your problem!

enter image description here

This would be my second guess in gconf!

enter image description here

share|improve this answer
    
Unfortunately no, this one is set to F4 (by myself) and works fine. Thanks anyway. –  pled Mar 9 '12 at 18:50
    
You are welcome pled! I edited my post with a second possible solution. Hopefully this does the trick for you?! –  v2r Mar 9 '12 at 19:36
    
The answer is still No :-( The "run_command_terminal" key is set to F4 here as well. Actually, I think it is related to the setting related to the "rename default behaviour (F2)" which is stored somewhere in dconf or gconf. I know I have been modifying such key, but cannot remember where it is. Thanks again for helping ! –  pled Mar 10 '12 at 10:37
    
I also looked within "dconf", but couldn't find something useful there. Maybe "GConf Cleaner" which is available through the Ubuntu Software Center can restore the old key-shortcuts, though i haven't tried it! Good LucK!! –  v2r Mar 10 '12 at 12:55
    
I tried GConf-cleaner without success. I ended backuping then deleting ~/.config/dconf/user, and it worked. F2 is back ! it is not a big work now to personalize it again, so all is fine. Thanks. –  pled Mar 10 '12 at 18:13
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.