Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using google chrome (not chromium) in ubuntu 11.10. I have installed all bangla fonts, set encode to unicode and set bangla font in chrome. It shows all bangla fonts excepts facebook profile name. Chrome show blank box instead of facebook bangla profile name. But it shows the bangla profile name in title bar. What kind of problem is this? How can i solve this?

image example: [see, title bar shows the bangla profile name]

enter image description here

Note: I am using latest google chrome. It shows something link this 15.0.874.121 in chrome about window. i can't find any version.

EDITED VERSION: I discover more. See the image below enter image description here

In inspect element bangla [একাদশে বৃহস্পতি] is showing but in browser is block. Other bangla is working in chrome like that,

<html>
    <head>
        <meta http-equiv="Content-Type" content="text/html; charset=utf-8"
    </head>
    <body>
        কি খবর দাদা?
    </body>
</html>

Above code shows perfectly in chrome.

share|improve this question
    
This is a known issue: code.google.com/p/chromium/issues/… . For now, may be you could use Firefox. –  The Terminator Mar 9 '12 at 17:00
    
Do you still have the issue? What is the purpose of the bounty you just started? –  jokerdino Mar 20 '12 at 5:58
    
I have solved the problem after the bounty started. –  shantanu Mar 20 '12 at 12:03

2 Answers 2

The problem might not be version bug as other answer suggesting, since it is still in chrome 29. A more concrete solution could be this.

  1. First Download a standard Bangla font, such as Solaiman Lipi.

  2. Install the font by copying it to either your user specific ~/.fonts folder or for system-wide effect in /usr/share/fonts/truetype folder.

  3. Then close (if it is opened) and open the Google chrome.

  4. Go to Settings, click on Advanced settings, in Website content section, click on the customize fonts button.

  5. In the sans-serif font section, change the font to Solaiman Lipi.

This should solve the problem.

Credit: This page on blogspot

Some alternative fonts:

You could also install lohit bengali font and use it. to install use the command in a terminal:

sudo apt-get install fonts-lohit-beng-bengali

Or you might want to test some of the fonts from omicron-lab site

share|improve this answer
up vote 1 down vote accepted

I solved the problem with newer chrome. It fixed in version 17.0.963.79. So the problem was previous version bug.

share|improve this answer
    
This problem is still present in Chrome version 28, 29 in 13.04. Might not be a version bug. –  Anwar Shah Sep 20 '13 at 17:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.