Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install the Nvidia 555M driver on my Lenovo Y570. I've tried all the advises here and other sites but I couldn't solve the problem.

  1. I downloaded the graphics card driver from the nvidia site for linux X64
  2. I tried to install it but a warning appears that I have to close x server.
  3. I use Alt+Ctrl+F1 and then type sudo service lightdm stop to stop the X server
  4. After this I can easily install the NVIDIA driver. but there was a problem: I couldn't get back to x server when I typed sudo service lightdm start. Again the black screen appeared.
  5. After deleting xorg.conf file I again can see the screen as opened as first installation of Ubuntu.

Edit: After trying too many things again the failure. I am adding what i tried till now. If you can help I will be very glad to you.

Thanks for your advise but it didn't work :( There is no problem with stopping lightdm and then installing nvidia driver for Geforce 555m. The main problem that I have to deal with is that sudo service lightdm start doesn't work after installation. A warning appears, saying "no screen found". Unless I delete /etc/X11/xorg.conf I cannot start the X server. so I couldn't install Bumblebee.

Then I tried this: after deleting the xorg.conf file to start with x server I copied xorg.conf.backup file to xorg.conf. I again tried to install Bumblebee and I get it but when I rebooted the laptop, the X server problem appeared again. I think main problem is to restart lightdm.

share|improve this question

This is a bug in somewhere in the kernel or BIOS and not the driver. Have a look at these for a workaround:

  1. You'll need to remove the drivers and xorg.conf file (look at the link in step 3 below)
  2. Then install the hack for working around a kernel/BIOS issue.
  3. Then proceed with installing Bumblebee
share|improve this answer

i think These is a Optimos graphic card... it worked on my gt 540m..


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.