Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running 11.10 and am trying to apply the fix to this bug in Empathy, shown at the very bottom. There is an updated package for the offending component available in the Precise repository, and someone even posted a backported .deb package for use on Oneiric. However, when I try to install that package, it seems to have a dependency on a package that isn't available for Oneiric:

(Reading database ... 254452 files and directories currently installed.)
Preparing to replace telepathy-indicator 0.0.7-0ubuntu1 (using telepathy-indicator_0.1.1-0ubuntu1_amd64.deb) ...
Unpacking replacement telepathy-indicator ...
dpkg: dependency problems prevent configuration of telepathy-indicator:
 telepathy-indicator depends on libunity9 (>= 3.4.6); however:
  Package libunity9 is not installed.
dpkg: error processing telepathy-indicator (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 telepathy-indicator

The person who posted the backported telepathy-indicator package indicated that it depends upon libunity-dev-5.0; the latest version in the Oneiric repositories is a 4.0 vintage. I also can't find a libunity9 available for Oneiric, so I'm wondering: is it possible to just add the Precise repository to my list and pull the updated packages from there, or should I not expect that they would operate correctly?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

I'm pretty sure that it would operate correctly. However, I strictly discourage you from doing so.

The point is that adding these repositories is almost exactly the same as upgrading to 12.04. Indeed, when you click the 'upgrate to precise' button, the only thing that gets done (except for several scripts) is that Precise repositories are added to your system, and then it continues as a normal update, which pulls all newer packages from Precise repository.

You won't find libunity9 (Unity 5) on Oneiric. You won't be able to install that manually too, because it has tons of dependencies that will never be met on Oneiric.

This said, your only chance to install that particular .deb package is to forcefully use the precise repository. However, instead of adding this repository manually, use the Distribution Upgrade option to upgrade to Precise, as it will ensure you will have a smooth, safer upgrade.


As a side note, consider notifying the appropriate person about your problem, I am prety sure one can backport this fix to Oneiric in a proper manner, so that it won't have such unmet dependencies.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.