Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using ubuntu 10.04. The font of gnome became very weird when I surfed the Internet.

Screenshot

I have used it for several months since the 10.04 is released. And I always install all the updates. It's the first time to meet such problem. I'm wondering what's the root cause.

share|improve this question
    
What website did you surf to when that happened? –  JanC Nov 3 '10 at 13:05
    
I think you have a problem whit the video card driver you can add some configuration of pc ... or dmesg –  Davide Feb 20 '11 at 12:23

4 Answers 4

I suggest you take a look at the question "Reset gnome font configuration?" which has an answer saying how to reset the GNOME font configuration, which I include a summary of below.

Try running the following in a terminal (Applications->Accessories->Terminal):

gconftool-2 --unset /desktop/gnome/interface/font_name
gconftool-2 --unset /desktop/gnome/interface/document_font_name
gconftool-2 --unset /desktop/gnome/interface/monospace_font_name
gconftool-2 --unset /apps/metacity/general/titlebar_font
gconftool-2 --unset /apps/nautilus/preferences/desktop_font 
share|improve this answer
    
Thanks for your answer. I have restarted the system to get things work again. The weird issue doesn't reproduce until now. –  Kane Nov 4 '10 at 2:15
    
@Kane (assuming the issue doesn't come up for you again) it is perfectly acceptable on this site to "answer your own question" - I suggest you do that in this case, for the benefit of anyone else with a similar problem. :) –  8128 Nov 4 '10 at 8:22
    
thanks for giving me a guide. :) –  Kane Nov 4 '10 at 9:46

This looks a lot like glyph cache corruption. That's certainly not a real font or character set, but instead it is chopped up and mixed around pieces of the regular latin alphabet. You also have some random corruption in the form of those dashed lines on the right hand side.

This kind of bug is usually caused by your video card drivers, although it is not usually this severe. For example see the screenshots on this bug report:

https://bugzilla.redhat.com/show_bug.cgi?id=495323

It can also be caused by an overheating or failing video card or other hardware problems.

share|improve this answer
up vote 1 down vote accepted

I have restarted the system to get things work again. The weird issue doesn't reproduce until now.

share|improve this answer

Your fonts configurations are on ~/.font.conf Try to rename it and restart your computer. If it works I think you can delete it, though you can keep it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.