Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In gconf-editor, apps>metacity>general I have set up "focus_mode" to "sloppy" and "auto-raise" to "false".

Now the focus follows the mouse. Anyway, when I have several windows opened, and I close the one on top, the window immediately under the "x" button raises.

I would like that the system respect the "order" of the windows instead.

Here is an example: I have a top window, a middle window, and a background terminal:

before clicking

If I close the window, I obtain the terminal on top, instead of the middle window. This happens because the terminal is just under the "x" of the top window.

after clicking

It was more logical (and if was like that, before Unity), to obtain the middle window on top instead of of the terminal, like that:

what I wish

This is particularly annoying with maximized background applications. Someone knows how to obtain (again) this effect? it is particular disturbing if there is a maximized application and several little windows on it.

Moreover, if focus-follows-mouse is enabled, it is possible to remove/rename desktop icons only if the desktop is completely free.

share|improve this question
    
You have filed a bug on this: bugs.launchpad.net/focus-follows-mouse/+bug/958432 –  fossfreedom Apr 20 '12 at 10:05

1 Answer 1

up vote 1 down vote accepted

I suggest also turning off /apps/metacity/general/auto_raise.

The focus will still go to the "other" window, but the windows' stacking order remains the same, which makes it easier to refocus on the (new) fully exposed top window (just move the mouse over it, of course).

share|improve this answer
    
This solved my problem!!!!!!!!! –  leonard vertighel May 3 '12 at 10:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.