Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed ubuntu 11 and the maximum resolution that it will let me set it at is 1024 x 768. My graphics are onboard, its the intel 82845g. Trying to increase the resolution and support the video more smoothly.

UPDATE:

user1@pc1:~$ xrandr | grep maximum
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 2048 x 2048
user1@pc1:~$ gtf 1280 1024 59.9

  # 1280x1024 @ 59.90 Hz (GTF) hsync: 63.49 kHz; pclk: 108.70 MHz
  Modeline "1280x1024_59.90"  108.70  1280 1360 1496 1712  1024 1025 1028 1060  -HSync +Vsync

user1@pc1:~$ xrandr --newmode "1280x1024_59.90"  108.70  1280 1360 1496 1712  1024 1025 1028 1060  -HSync +Vsync
X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  149 (RANDR)
  Minor opcode of failed request:  16 (RRCreateMode)
  Serial number of failed request:  20
  Current serial number in output stream:  20
user1@pc1:~$ 
share|improve this question
1  
No need to paypal. Please provide more details. Could you provide the output of this command line on a terminal: xrand -q and this one : lspci | grep VGA and this one: sudo lshw -C video What Laptop/computer model do you have? what Ubuntu version you installed: 11.04 or 11.10? Is it an external monitor or a the laptop screen? If an external monitor, how do you plug it? VGA, DVI, HDMI? –  Hanynowsky Mar 9 '12 at 4:39
    
this is ubuntu 11.10, it's a monitor that's about 5 years old, but it runs high resolutions fine in windows xp. I have it hooked up through VGA cable - It's a gateway PC, I got the machine for free when someone else upgraded - I don't know the model number - it's probably 5 years old easy. It has only PCI slots, and one AGP. I would really like to be able to run atleast 1280 x 1024 resolution. I don't mind buying a video card. –  djturbojp7 Mar 9 '12 at 23:40
    
Here is the output. user1@pc1:~$ xrandr -q Screen 0: minimum 320 x 200, current 1024 x 768, maximum 2048 x 2048 VGA1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm 1024x768 60.0* 800x600 60.3 56.2 848x480 60.0 640x480 59.9 user1@pc1:~$ –  djturbojp7 Mar 9 '12 at 23:40
    
user1@pc1:~$ lspci | grep VGA 00:02.0 VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01) user1@pc1:~$ –  djturbojp7 Mar 9 '12 at 23:40
    
user1@pc1:~$ sudo lshw -C video [sudo] password for user1: *-display description: VGA compatible controller product: 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device vendor: Intel Corporation physical id: 2 bus info: pci@0000:00:02.0 version: 01 width: 32 bits clock: 33MHz capabilities: pm vga_controller bus_master cap_list rom configuration: driver=i915 latency=0 resources: irq:16 memory:f0000000-f7ffffff memory:ffa80000-ffafffff user1@pc1:~$ –  djturbojp7 Mar 9 '12 at 23:41
show 4 more comments

1 Answer 1

Use xrandr to make sure that the new mode can fit within the maximum framebuffer size

xrandr | grep maximum

Use gtf to create a mode line

gtf 1280 1024 59.9

(59.9 is the refresh rate) Add the new mode using xrandr

xrandr --newmode "1280x1024_59.90"  ............

replace the above dots (........) by what the gtf command gives you after the mode is created. It should be something like this: 106.29 1440 1520 1672 1904 900 901 904 932 -HSync +Vsync

Add this newly added mode to the desired output (VGA/LVDS etc - VGA in your case)

xrandr --addmode VGA 1280x1024_59.90

Choose the new mode

xrandr --output VGA --mode 1280x1024_59.90

See a similar question: Can't enable intel driver 82845g/gl (brookdaleg) chipset

Merely speaking, It also indicates that installing Lubuntu solves the issue.

For your Nvidia card: see solution : Display resolution with NVIDIA

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.