Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a MacBook 6,1 with both, OS X and Windows XP partitions. I try to boot from my USB drive which has Ubuntu installed and working (tried on friends computer) and it booted fine.

I try to boot it and it boots into Windows. I am using "rEFIt" and "Live-CD's" work. and USB's and external hard-drives don't seem to.

I tried this guide, and the problem with the answer is, that I am not running a "Live Boot" but an actual install. I took a Live CD and installed Ubuntu onto my flash-drive (32 gig) and I use it as an external hard-drive.

share|improve this question

closed as too localized by qbi, TheX, Uri Herrera, belacq, Jorge Castro Feb 28 '13 at 22:51

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Possible duplicate of askubuntu.com/q/10561/43660 This answer worked for me: askubuntu.com/a/25020/43660 –  Chan-Ho Suh Mar 9 '12 at 4:10
1  
@C S Not at all, I have Ubuntu installed on a USB and all I want to do is boot into the USB. I don't want to use it to install anything. The USB is simply acting as an external hard-drive. EDIT: It's not that it doesn't boot, it does for a second and then instantly switches. –  Sean H Mar 9 '12 at 4:39
1  
The problem, as you stated it, is booting off the USB. In the other thread, the reason for wanting to do so was installing, but it's the same problem: not being able to boot off the USB. I suggest you read the other thread and follow the link I recommended. AFAIK, that (and related methods) is the only way to boot Ubuntu off a USB on a Mac. –  Chan-Ho Suh Mar 9 '12 at 4:41
    
The USB did boot fine before I had Windows installed...I had to install windows for programming purposes. –  Sean H Mar 9 '12 at 4:50
1  
Guide didn't help, I have no .img to use. –  Sean H Mar 11 '12 at 14:45