Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Aspire 5740 with an Intel Core i3, and Fn + arrow keys still call up the brightness adjuster, but have no effect on actually changing the brightness. The slider moves, but the brightness remains at maximum. System settings also allow me to move the slider, but again, with no effect.

It's killing my battery - please tell me what to code in to fix this!

share|improve this question

2 Answers 2

It's a known bug. You can view it here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/543294 Well someone posted a workaroudn like this:

1. Open a terminal (Program - Accessories - Terminal)
2. Type in "sudo gedit /etc/default/grub" (without the "")
3. Find the line that says: GRUB_CMDLINE_LINUX="quiet splash"
4. Edit it so it says: GRUB_CMDLINE_LINUX="quiet splash acpi_backlight=vendor"
5. Save and exit
6. Run the command "sudo update-grub" (again without quotes of course)
7. Reboot and enjoy!

and yeah, it worked for me

share|improve this answer
    
You should use gksudo instead of sudo for graphical programs such as gedit. –  Dan Jul 26 '12 at 7:33
    
now I get dmesg "acer_wmi: Unknown function number - 4 - 0 (that final digit counted down to 0 from 4 with each hit of the Fn-leftarrow combination) –  jcomeau_ictx Nov 26 '13 at 12:09
    
my problem is on a D270 though: bugzilla.kernel.org/show_bug.cgi?id=44451 –  jcomeau_ictx Nov 26 '13 at 12:21
    
acer-wmi is blacklisted in etc/blacklist.conf. removing it from there might fix the problem temporarily. Also here is one similar reported bug, the fix seems good to me. Especially the comment #7 and #10 –  ashutosh Nov 26 '13 at 19:59

First back up:

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.backup

Then:

sudo gedit /etc/X11/xorg.conf

Find the "Option "No Logo" " Add this underneath:

Option "RegistryDwords" "EnableBrightnessControl=1"

(Including all the quotes)

Then save either restart. That should work but you may need to edit grub, try the above first.

share|improve this answer
    
Ubuntu 12.04 no longer seems to store its xorg.conf at /etc/X11/xorg.conf... –  Cerin May 2 '12 at 1:07
    
It doesn't use much configuration anymore, xorg has been developed to give good defaults instead. You can put a config or part of a config in /etc/X11/xorg.conf even though there isn't one by default. It's also possible to add configuration information to a file in /etc/X11/xorg.conf.d . That's what I do to set some touchpad attributes. –  John S Gruber Aug 23 '12 at 17:47

protected by Community Dec 15 '12 at 10:37

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.