Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have two FullHD monitors attached to my ATI graphics card [2]. The resolution of both of them is detected properly without any modifications to /etc/X11/xorg.conf. I can run both of them in clone mode. However, when I try to run them next to each other, I got the following error: The selected configuration for displays could not be applied. If tried to fix this according to [1]. My xorg.conf now looks like this:

Section "Module"                                                                
        Load    "glx"                                                           
EndSection                                                                      

Section "Screen"                                                                
        Identifier      "Default Screen"                                        
        DefaultDepth    24                                                      
        SubSection "Display"   
              # The 1088 is the smallest multiple of 32 >= 1088
              # see manpages                                               
              Virtual 1920 1088                                               
        EndSubSection                                                         
EndSection 

This does not seem to be parsed properly. After restarting X, I cannot set resolutions beyond 1600 or so any more. /var/log/Xorg.0.log gives:

[    15.676] (II) fglrx(0): Not using mode "1920x1080" (width too large for virtual size)
[    15.676] (II) fglrx(0): Not using mode "1680x1050" (width too large for virtual size)

Are my modifications syntactically incorrect? According to the man page, it should be fine. Any ideas?

OS: Ubuntu 11.10 64bit

[1] http://askubuntu.com/a/75546/5023
[2] 01:00.0 VGA compatible controller: ATI Technologies Inc Juniper [Radeon HD 5700 Series]

share|improve this question
add comment

2 Answers

if you want both screens next to each other your virtual size must be at least

Virtual 3840 1080

EDIT:

It seems like you need to extend the height too, so using

Section "Screen"
        Identifier      "Default Screen"                                        
        DefaultDepth    24                                                      
        SubSection "Display"
              Virtual 3840 3840                                               
        EndSubSection
EndSection

as xorg.conf works for me

share|improve this answer
add comment

Have you checked the output of /var/log/Xorg.0.log ? Your Screen section looks correct, what does your Monitor section look like?

Section "Monitor"
    Identifier  "Monitor1" 
    HorizSync   28-110 
    VertRefresh 43-90 
    Modeline "1920x1200" 162 1920 1984 2176 2480 1200 1201 1204 1250 +hsync +vsync
EndSection

Section "Monitor"
    Identifier  "Monitor2" 
    HorizSync   28-110 
    VertRefresh 43-90 
    Modeline "1920x1200" 162 1920 1984 2176 2480 1200 1201 1204 1250 +hsync +vsync
EndSection

If checking your Monitor sections doesn't fix your issue, my next step would be to remove some of your GUI based settings files.

~/.dt

~/.dtprofile

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.