Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 11.10. I was using GIMP 2.6 from the repo but I read that GIMP 2.7 has merged windows, I wish I hadn't but I wondered it and added the following PPA: matthaeus123/mrw-gimp-svn

After that it required me to add two other repos:

GIMP 2.7.5 Will not work with the current glib and gtk in Oneiric. To fix the problem install these repos

deb http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu oneiric main

deb http://ppa.launchpad.net/ricotz/testing/ubuntu oneiric main

I added those PPAs and in somewhere a pop-up with "partial-update" appeared I applied the update and restarted Ubuntu. After the restart, my theme was a little bit changed, when I right-click the color is not gray but white and most importantly I am not able to reach:

  • Software Sources, when clicked it looks as if opening and then closes.

  • sudo gedit /etc/apt/sources.list doesn't work, because my Gedit doesn't work.

  • Preferences in Nautilus, when clicked it closes Nautilus.

I would like to revert everything I updated. I would like to downgrade/remove the packages ppa:gnome3-team/gnome3 and ppa:ricotz/testing PPAs but I am unable to do it.

So, I am stuck. How do I restore everything?

share|improve this question
    
run "sudo apt-get -f install" might straighten out the partial update –  Ringtail Mar 8 '12 at 21:27
    
Thanks for answer @BlueXrider, but nothing changed. Everything is same. –  Şâkir Aşçı Mar 8 '12 at 21:36
    
Gimp 2.7.5 introduces new plugins which requires new libraries which in turn require a newer version of Gnome, that's why it's all messed up, for me and apparently for you Themes in newer versions of Gnome are broken. –  Uri Herrera Mar 8 '12 at 22:25
    
Only way without re-installing is, get yourself another DE, completely remove everything Gnome, and re install the version in the repos. –  Uri Herrera Mar 8 '12 at 22:26
    
Yes, that's exactly what happened, new libraries messed everything up. I was able to remove GIMP 2.7 and now GIMP 2.6 works; however, my Themes are broken, and most importantly Software Sources is unavailable both from Software Centre and from terminal. –  Şâkir Aşçı Mar 8 '12 at 22:30

2 Answers 2

sudo apt-get install ppa-purge    

sudo add-apt-repository ppa:gnome3-team/gnome3    
sudo add-apt-repository ppa:ricotz/testing

*without previous two commands I had problems with "ppa-purge"

sudo apt-get update && sudo apt-get upgrade    
sudo ppa-purge ppa:ricotz/testing    
sudo ppa-purge ppa:gnome3-team/gnome3

reboot

share|improve this answer
    
Thanks for your answer, I found that solution somewhere and tried, but did not work. I mean, the packages were removed but my Theme and applications still don't work. So, still searching... –  Şâkir Aşçı Mar 9 '12 at 12:45
up vote 1 down vote accepted

I have found the solution!

As @solomenikmi said, I applied these commands:

sudo apt-get install ppa-purge    

sudo add-apt-repository ppa:gnome3-team/gnome3    
sudo add-apt-repository ppa:ricotz/testing

However, it did not solve the problem related to Themes and applications. So, I started searching and while searching I found a solution and applied the following:

sudo apt-get remove libgtk-3-common
sudo apt-get dist-upgrade
sudo apt-get install gnome-panel
sudo reboot

It seemed as if everything worked well; however, that solution was proposed for Ubuntu 11.04 but I am using Ubuntu 11.10 and it messed up the system again! This time, I was not even able to reach to login screen of Ubuntu, after I press the power button of my laptop, the start-up was freezing at Checking battery state... [ OK ]. After searching again, I applied those following commands:

sudo apt-get install lightdm-gtk-greeter
sudo apt-get install unity-greeter
sudo reboot

And that was it. I succeeded to return to the state where my themes and applications work just like before installing GIMP 2.7.5!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.