Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How do I fix this error? Java could not reserve enough memory to start the server

Hope you guys can help me.

share|improve this question

closed as too localized by Eliah Kagan, jrg Dec 26 '12 at 1:45

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Can you maybe edit your question to include a little about what you have done so far, and what you are trying to do? –  BryceAtNetwork23 Mar 8 '12 at 19:43
add comment

1 Answer 1

Although not the right place for Java questions (should be in stackoverflow) - you should execute the JVM with a -Xmx argument that specifies a larger size of heap. (e.g. -Xmx1500M). Increase it until you have enough memory to run your server.

share|improve this answer
    
Sorry about that, how would I go about doing this? Pretty newby with linux. (This is for a vps) :) thanks for your reply. –  TheCyberShocker Mar 8 '12 at 18:48
    
Is there a way to edit a file in java and do it from there? –  TheCyberShocker Mar 8 '12 at 19:22
    
@TheCyberShocker How you would do this depends on how you are running the server. For example, if you were running the server with the command java NameOfTheServerProgram you would run java -Xmx1500M NameOfTheServerProgram instead. Right now we'll probably close your question since it appears abandoned and you haven't provided some important information that was requested. But if you still want help with this, please edit your question to provide more information (and if it's already closed, you can then flag it to request it be reopened). –  Eliah Kagan Dec 21 '12 at 9:30
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.