Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Ubuntu server is installed on hard drive with very simple partitioning

/dev/sdd1   *           1        1824    14647296   83  Linux
/dev/sdd2            1824        3283    11718656   83  Linux
/dev/sdd3            3283        4864    12702720   82  Linux swap / Solaris

So about 14GB is allocated for / and about 12GB for /home. The rest is swap.

Today I noticed when I login I got a warning that running out of space. df shows the following

Filesystem            Size  Used Avail Use% Mounted on
/dev/sdd1              14G   13G  619M  96% /
none                  2.9G  260K  2.9G   1% /dev
none                  2.9G     0  2.9G   0% /dev/shm
none                  2.9G  852K  2.9G   1% /var/run
none                  2.9G     0  2.9G   0% /var/lock
none                  2.9G     0  2.9G   0% /lib/init/rw
/dev/sdd2              12G  2.6G  8.0G  25% /home

At this point I am trying to understand what eats 13G on my root partition. du shows the following output

$ sudo du -hxL --exclude="/home" --max-depth=1 / # excluding home because
                                                  it's other partition

0       /sys
4.0K    /selinux
4.0K    /mnt
447M    /lib
4.0K    /opt
1.9G    /usr
64M     /etc
447M    /lib64
31M     /boot
8.2M    /sbin
8.0K    /man
48K     /root
358M    /var
0       /proc
0       /dev
4.0K    /srv
16K     /lost+found
28K     /tmp
12M     /bin
3.2G    /

parted

Disk /dev/sdd: 40.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system     Flags
 1      1049kB  15.0GB  15.0GB  primary  ext4            boot
 2      15.0GB  27.0GB  12.0GB  primary  ext4
 3      27.0GB  40.0GB  13.0GB  primary  linux-swap(v1)

The sum is far not 13G, in fact it's around 5G. So what exactly takes space on my root partition?

share|improve this question
    
Can you try du -hx / | sort -h instead? –  elmicha Mar 8 '12 at 17:28
2  
Have you rebooted your server recently? If not, it could be a large file that has been deleted, but is still hold by a running process. Thus it won't be visible in the filesystem, but still use diskspace. –  Grumbel Mar 8 '12 at 18:07
    
@elmicha: same result (my sort doesn't have -h) –  Pablo Mar 9 '12 at 1:14
    
@Grumbel: The uptime was just 1 day. There must be some way to list such files. I've also tried to reboot again, but nothing changed. –  Pablo Mar 9 '12 at 1:15
    
Try to boot from a LiveCD. You could examine the filesystems while not being in use. –  lgarzo Mar 9 '12 at 15:05

2 Answers 2

up vote 1 down vote accepted

I bet if you umount /dev/sdd2, you will see another 12GB /home folder

share|improve this answer
    
hmm... how to check that without umount? Device is currently actively used and I can't umount it. But you might be right, because df -x gave me 2 4.0K /home items in output... So what I've done wrong? –  Pablo Mar 9 '12 at 14:40
    
In fstab I have 3 mounts, for /, /home and swap. No double homes... –  Pablo Mar 9 '12 at 14:44
    
UUID=07476b60-d9da-49ca-b6f8-442713fc112e /home ext4 defaults 0 2 <--- could this very last 2 be the one? –  Pablo Mar 9 '12 at 14:48
    
I guess no, it's fschk :( –  Pablo Mar 9 '12 at 14:53
    
Can you check the sizes with gparted –  jet Mar 9 '12 at 15:32

Try the following in a terminal

$ sudo apt-get autoclean 

OR Try to kill updatedb process

$ ps aux | grep updatedb

Note the PID.

$ kill PID
share|improve this answer
    
ps shows I don't have updatedb running. I try to avoid auto* actions, rather I would like to understand what exactly is eating up the space. –  Pablo Mar 9 '12 at 1:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.