Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I switched to a new laptop, a Dell Latitude E6520. This laptop has a NVidia/Intel hybrid GPU setup. When "NVidia Optimus" is enabled then Linux (Ubuntu Oneiric) sees both GPUs:

lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: nVidia Corporation GF108 [Quadro NVS 4200M] (rev a1)

When I disable "Nvidia Optimus" then Linux only sees the NVidia GPU. Everything works fine using the commercial NVidia driver (Only when Optimus is disabled) but I would prefer using the Intel GPU instead. I can do this by enabling the "NVidia Optimus" setting in the BIOS and by removing the commercial NVidia video driver. The Intel driver runs fine even with 3D acceleration. But my problem is: No external displays are detected. Here is the output of xrandr:

$ sudo xrandr -q
Screen 0: minimum 320 x 200, current 1600 x 900, maximum 8192 x 8192
LVDS1 connected 1600x900+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
   1600x900       60.0*+   40.0  
   1440x900       59.9  
   1360x768       59.8     60.0  
   1152x864       60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)

I tried attaching the display to VGA, DVI and HDMI. The output is always the same. The Gnome Display Settings Dialog also only sees the internal laptop display.

So how can I use external displays with the Intel driver? Or are external displays in a NVidia/Intel hybrid setup only connected to the NVidia GPU and even Windows has to switch to the NVidia GPU when external displays are attached?

share|improve this question

3 Answers 3

You should blacklist the nvidia, nv and nouveau module in /etc/modprobe.d/blacklist.conf I am not sure if your machine supports external displays when running the intel gpu, I have a Lenovo W520 and on this machine external displays aren't supported when running on intel gpu.

share|improve this answer
up vote 0 down vote accepted

Found the problem. I should have mentioned that I'm using a docking station. And after taking a closer look on it I found out that there is also a VGA connector on it. So when docked the VGA port of the laptop seems to be deactivated. But the VGA port on the docking station works when using the Intel GPU. I also had to remove the DVI cable from the external monitor because it didn't switch to VGA mode otherwise.

Well, I would have preferred using DVI or HDMI but VGA runs fine, too. So finally I can use stable Intel graphics in dual-head mode. Nouveau and commercial NVidia are too buggy in Gnome Shell for my taste.

share|improve this answer

I'm using a W530 machine with the same findings. On the dock, with Windows nvidia driver, the driver automatically switches to the nvidia driver. So the behavior is the same on a Windows machine except with Linux we need to manually change the driver with Prime. I'm assuming that this is because of how the X-server handles things but I sure would like some automatic switching to occur.

share|improve this answer
    
This would be more properly a comment than an answer –  Charles Green Jun 25 at 4:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.