Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

UFW is blocking some outgoing connections on my server, such as Akismet, the spam killing plugin for my Wordpress site. According to Akismet's firewall info I need to allow contact with four IPs. My ufw rules allow all outgoing traffic. I tried explicitly adding rules both for the IPs concerned, but it made no difference.

Mail on the same server is also blocked when doing a CNAME lookup. This makes the logs, whereas ufw doesn't.

Apache serves pages fine, and I can get in over SSH, etc in accordance with ufw's inbound rules.

Clearly I've just got ufw set up wrong, as everything works fine when I disable ufw.

share|improve this question
    
Hard to know. Can you please update your post with your ufw rules and a log of the dropped traffic. –  bodhi.zazen Mar 8 '12 at 0:41
    
All I have in ufw at the moment is Status: active Logging: on (low) Default: deny (incoming), allow (outgoing) New profiles: skip To Action From -- ------ ---- 22 ALLOW IN Anywhere 80/tcp ALLOW IN Anywhere 443 ALLOW IN Anywhere 21/tcp ALLOW IN Anywhere 25/tcp ALLOW IN Anywhere –  Seret Mar 8 '12 at 10:10
    
how do you know that akismet is being blocked by ufw, if it's not showing in your logs? It seems more likely that it's being blocked by a browser ad-blocker or similar instead. –  ImaginaryRobots Mar 13 '12 at 16:33
    
Because it works fine with ufw disabled. Mail is also being blocked, and that one does show up in logs as failing CNAME lookup. I have actually added DNS to ufw btw, but still get the same. –  Seret Mar 13 '12 at 21:52
3  
can you try the following: sudo iptables -Z then try connecting to Akismet again. Then sudo iptables -L -v -n | pastebin which will show the dropped packets. –  cprofitt Mar 17 '12 at 0:07
show 6 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.