Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On Ubuntu 10.04 server 32bit it worked on 20dBm/100mW, but on 11.10 it just can use 17dBm/50mW. Why? How can I use this wireless card on 11.10 as I used it on 10.04?

share|improve this question
1  
Which regulatory domain are you in (i.e. which country)? For example, in Japan you're not allowed to transmit over 50mW (if I'm not mistaken). You can check which regulatory domain Ubuntu put you in with this command in the terminal: grep CRDA /var/log/kern.log. –  taneli Mar 15 '12 at 5:06
1  
Which driver is the card using ath5k or ath9k? –  cprofitt Mar 16 '12 at 12:46

1 Answer 1

From what I am reading there are issues with this card and the newer ath9k driver the kernel is using.

Suggestions that have been made are:

This one is the one I have seen the most and the one people claim worked the most. I do not have your card so I can not test. create

/etc/modprobe.d/ath9k.conf

then add the following line:

options ath9k nohwcrypt=1

another suggestion is:

echo 1 > /sys/kernel/debug/ieee80211/phy0/ath9k/disable_ani

share|improve this answer
    
didn't helped, sorry –  LanceBaynes Mar 17 '12 at 19:52
    
I have not seen any other suggestions, but there are many reported issues about this. My hope is that it will be addressed in future kernel releases. –  cprofitt Mar 19 '12 at 0:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.