Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I followed these instructions to configure natural scrolling for my normal ubuntu (11.04) desktop, and they worked just fine:

http://maketecheasier.com/reverse-mouse-scrolling-direction-in-ubuntu/2011/09/16

but those settings, even when I'm logged in as the same user through nxserver remotely don't apply. So I tried to adjust the scroll direction manually using xinput like so:

 xinput list 
"pointer"   id=0    [XPointer]
"keyboard"  id=1    [XKeyboard]

and then:

 xinput get-button-map 0
X Error of failed request:  XI_BadDevice (invalid Device parameter)
  Major opcode of failed request:  131 (XInputExtension)
  Minor opcode of failed request:  3 (X_OpenDevice)
  Device id in failed request: 0x0
  Serial number of failed request:  15
  Current serial number in output stream:  15

to see the current button map, trying to change the mapping with:

 xinput set-button-map "pointer" 1 2 3 5 4 6 7 8 9 10 11 12 13 14 15 16
X Error of failed request:  XI_BadDevice (invalid Device parameter)
  Major opcode of failed request:  131 (XInputExtension)
  Minor opcode of failed request:  3 (X_OpenDevice)
  Device id in failed request: 0x0
  Serial number of failed request:  15
  Current serial number in output stream:  15

results in the same error. Anyone know how to do this?

share|improve this question

1 Answer 1

up vote 2 down vote accepted
+50

Try xmodmap -e "pointer = 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16" that works for me.

share|improve this answer
    
yes, thank you! woohoo! –  chrismarx Apr 20 '12 at 14:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.