Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

If I am using the proprietary driver, I don't get a good boot screen.

share|improve this question

3 Answers 3

up vote 2 down vote accepted

There is also a workaround to make plymouth use framebuffer: http://news.softpedia.com/news/How-to-Fix-the-Big-and-Ugly-Plymouth-Logo-in-Ubuntu-10-04-140810.shtml

share|improve this answer
    
I wouldn't trust softpedia from my experience. –  myusuf3 Aug 5 '10 at 13:27
    
@garbagecollection: Than write some better information. There is enough space here or at the Ubuntu community help wiki (help.ubuntu.com/community) –  txwikinger Aug 5 '10 at 13:52
  • First open the software center

enter image description here

  • Install v86d

enter image description here

  • Now Press Alt + F2 and enter gksu gedit

enter image description here

  • Now click on 'Open' and Press the pencil button .

enter image description here

  • Now paste /etc/default/grub

  • Now Replace the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" (Line no 11 according to gedit) with

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=1280x1024-32,mtrr=3,scroll=ywrap (you can replace 1290x1024 with your own resolution .

-Also replace #GRUB_GFXMODE=640x480 (Line 25 according to gedit ) with GRUB_GFXMODE=1280x1024

-Now your grub file looks like this

enter image description here

  • Save the file .

  • Now click open again and paste /etc/initramfs-tools/modules in the location .

  • Paste uvesafb mode_option=1280x1024-32 mtrr=3 scroll=ywrap at the end of the file (again you can replace 1280x1024 with your own resolution) .

enter image description here

  • Now create a new file and paste FRAMEBUFFER=y and then save the file with the name splash to /etc/initramfs-tools/conf.d .

  • Now Open the terminal (Ctrl + Alt + T) and paste this.

    sudo update-grub2 && sudo update-initramfs -u

  • You are done!!

Source

share|improve this answer

This depends on your definition of "good".

There is a fallback: usplash and/or xsplash. These should load automatically. They do here on systems where Plymouth doesn't work.

Plymouth requires KMS which is only available on open source drivers (AFAIK). This means if you're running the closed ATI/Nvidia drivers, you'll have an ugly boot experience.

I personally just turn off quiet and splash from the kernel arguments and watch a load of text scroll up the screen. It's only there for a few seconds, lets me know what's going on and it doesn't waste time loading up images.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.