Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have tested on the same PC with the same torrent/magnet links the following Torrent Clients:

Transmission
Ktorrent
Deluge
qBittorrent
Vuze

After 7 days of testing I noticed that the only one that took longer to start downloading and to keep an optimum/max download speed was Transmission. It was the slowest of them all to download the same torrents or magnet links which I tested 8 torrents and 4 magnet links from different sites and the one that took the most to start downloading or start after a pause/resume event. The other 4 just took less than 2 seconds for example to start downloading and to download the same content between 50% less time to 80% less time.

I think that Transmission has the same capabilities about downloading/resuming than the other torrent clients but it may be because of some configuration I need to do to get the same speed and effect than the others.

In my tests all torrent clients were tested with their default configurations. No changes were made. They were tested on the same PC, with the same network connection in the same time periods. So I am thinking that Transmission just needs a little bit of configuration tunning. I also set the ports for use to the same one for each. Checked the router for any blocking and anything related to the network.

What options can I change to make it so Transmission resumes a download faster (grabs the seeds faster) and keeps a fast download all the time (Stays with the seeds that offer the best connection for example). Both of which by the look of it are features that the rest of the torrent clients do already.

share|improve this question

2 Answers 2

up vote 4 down vote accepted

If you are using a router, make sure that the port used by Transmission for incoming connections is opened in your router (NAT port forwarding). As the other clients are faster, I suspect that they use a port that is already opened in your router.

In Transmission go to Edit > Preferences > Network and set the same port as in the other clients, and disable "Pick a random port every time Transmission is started". You can use the "Test Port" to see whether the chosen port is open.

It's also possible that your router is configured to accept UPnP or NAT-PMP port forwarding requests. If that is the case, you could enable the "Use UPnP or NAT-PMP port forwarding from my router" checkbox (instead of setting the port and opening it in the router manually).

share|improve this answer
    
I actually already tested this. Is not the port. I will update the question in regards to this because I also thought it was the router, port or something in between. At the end, it was not. –  Luis Alvarado Mar 7 '12 at 22:01

Just a heads up! If you are using Uncomplicated Firewall Wall (or any other firewall) ports 6969,80/udp should be open. Otherwise Transmission cant access some of the trackers. Hence lower download speeds.

share|improve this answer

protected by Community May 20 at 9:02

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.