Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having trouble even finding the right search terms to diagnose this problem. It's also hard to reproduce on my own machine.

When I enter a command in the terminal, occassionally I will see no results at all. I won't even see a new prompt. It seems like the display is getting corrupted. All it takes to clear it up is hitting Enter again. Then I will see a (second) new prompt, and the result of the previous command.

A similar thing is happening in Emacs. When I switch to a buffer, or scroll, occassionally there are several missing lines, or even portions of lines. If I highlight those lines, they become visable again.

I'm not even sure what system controls rendering in both Emacs and Terminal. I don't notice the problem in any other applications (other than those, I mainly use Chrome).

share|improve this question
    
It just happened in Emacs and I was going to take a screenshot, but as soon as I opened the unity menu, the missing characters reappeared. So it seems to clear up whenever the screen is refreshed somehow. –  Reed G. Law Mar 7 '12 at 16:29
    
Does it happen in a console (when you hit CTRL+ALT+F1), or only under GUI?. Have you tried alternative console emulators (like guake, konsole or any other)?. –  Javier Rivera Mar 7 '12 at 17:03
    
Only when inside Unity. I haven't tried alternate consoles. It's been happening a lot in irb (Ruby's REPL). –  Reed G. Law Mar 7 '12 at 17:51
    
At this point it looks like a bug in either compiz/graphic drivers or gnome console. Trying alternative consoles could help in narrowing it. –  Javier Rivera Mar 7 '12 at 18:17
    
Ok, I've started using guake and I like it so far. We'll see if it has the same issuee... –  Reed G. Law Mar 7 '12 at 19:31
show 3 more comments

1 Answer 1

It seems to be a bug in the NVidia drivers. Here are some solutions to the similar question:

Gnome-terminal doesn't refresh

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.