Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an HP printer connected to my Ubuntu 11.10 machine. I have 2 other Windows computers (Win7/Vista). Both of these Windows computers can view, install, and print a test page to the shared Ubuntu printer. The Windows computers cannot print anything to the Ubuntu printer except the test page under properties or during install. I have tried word and pdf files.

share|improve this question
    
Have you ever found a solution to this problem? I have the exact same one with a similar setup. –  waldrumpus Jan 24 '13 at 15:30
1  
@waldrumpus RmburaK's answer solved this for me –  Tobias Kienzler Apr 27 at 10:06
    
@waldrumpus Indeed, I had exactly the same issue, sharing over cups instead of samba fixed the issue for me. –  Arda Apr 28 at 12:55
add comment

4 Answers 4

In Linux stop sharing the printer through Samba.

Share it through CUPS instead: go to http://localhost:631/ and there will be spoe "Share printers" checkbox.

On Windows add a Network printer, and don't search for it; add manually this address:

http://servername_or_IP:631/printers/printer_name

printer_name is the name shown in the CUPS Web interface for your printer.

You will be prompted to choose the proper model and a driver will be installed. That's it.

Unlike Samba, advanced feature also work now.

share|improve this answer
2  
I'd vote +10 if I could. EASY and PERFECT solution. Thanks a ton :) –  Pitto Jun 15 '13 at 14:04
    
I had issues printing PDF pages and some excel sheets. Thanks a lot for this! :) –  Arda Apr 28 at 12:54
add comment

In the print dialog go to: Preferences->Document Options->Advanced Printing Settings-> select "DISABLED" (a drop-box)

It's a HP driver on Microsoft thing.

I have the F2280 (HP Deskjet F2200 Series). Had to disable 2-up printing on an 8-page PDF.

share|improve this answer
add comment

If he's already printed a test page you can bet samba is already installed. What you may want to play around with is the encoding/protocol. I think you may have to send print jobs in RAW format, or try one of the other formats it offers. I'm pretty sure that is where your problem will lay.

share|improve this answer
    
So, how do send print jobs in RAW format? How do I try that? –  Darren Farnsworth Mar 7 '12 at 21:46
add comment

This is a Ubuntu Guide For Windows Users: Connecting To Shared Printers On Windows Computers.

http://www.watchingthenet.com/connecting-to-shared-printers-on-windows-computers.html

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.