Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have install many applications and cheese was one of those but I can not open

I have tried cheese on debian 6.04 and cheese works fine but not on Ubuntu.

Maybe, I do not any drivers installed on the system? Because they are available. Do I have to install them?

If this is the cause of that, what can I do ,or when a driver it will be available? (I send a report 2 launchpad of the system)

and because of that I can not use neither Ubuntu 3d or gnome shell or play 3d games.

my hardware display on terminal using command lspci was:

01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter (rev 10)

(..just about every hardware is from Silicon Integrated Systems [SiS] on my laptop)


using cheese on terminal give me this error:

Xlib: extension "GLX" missing on display ":0.0". (cheese:4163): Clutter-CRITICAL **: Unable to initialize Clutter: The OpenGL version could not be determined

but after a new installation of ubuntu and update (did here a reboot)and new instalations of applications give me a different error before reboot on terminal that was:

(cheese:506): Clutter-CRITICAL **: Unable to initialize Clutter: Unable to find suitable fbconfig for the GLX context: Unable to find fbconfig with rgba visual

but them after rebooting after installing aplication give the same error

Xlib: extension "GLX" missing on display ":0.0". (cheese:4163): Clutter-CRITICAL **: Unable to initialize Clutter: The OpenGL version could not be determined


i have also installed ubuntu 12.04 and cheese works fine like for example stellarium even without a driver installed

so should i try to upgrade ubuntu 11.04 to ubuntu 12.04 beta? or wait for ubuntu 12.04 ?


i have upgrade ubuntu from 11.10 2 ubuntu 12.04 beta but still didn't work..

so i try to install ubuntu 12.04 beta from the start make a update and them install cheese it works like it did but them i also use synaptic and install all packages or applications from the markings on my ubuntu 11.10 .. and it seen all is working on the graphics better not fast but working like for exemple supertuxkart or stellarium

share|improve this question
    
What do you mean by "can not open cheese"? How do you start cheese and are there any errors? You don't need a driver to run cheese itself, even if you have no webcam connected the app should still open, although of course you wouldn't see a video stream in that case. –  Aras Mar 7 '12 at 3:28
    
i start cheese it appears on the dasher that is stating to run but few instants later close and cheese do not open i also see that when i try to open 3d games on ubuntu –  user49523 Mar 7 '12 at 4:26
    
i also have made a reinstalation but no changes –  user49523 Mar 7 '12 at 4:26
2  
try running cheese from command line (just type cheese and press enter) and see if you can find any errors in the output. You can also add any errors printed in the output to your question. –  Aras Mar 7 '12 at 5:56
    
Xlib: extension "GLX" missing on display ":0.0". (cheese:4163): Clutter-CRITICAL **: Unable to initialize Clutter: The OpenGL version could not be determined –  user49523 Mar 8 '12 at 2:23
show 2 more comments

2 Answers

I think the answer above is incorrect. I also can not start cheese on my 12.04 setup with an NVIDIA GT240 graphics card. I am using the proprietary driver and the webcam works perfectly with Skype. Camorama does not work either.

I am using 12.04 updated today 18th April. This is Beta 2 updated.

I did a fresh installation on another machine (using the daily build) and the problem does not occur. I would suggest doing a fresh installation at the end of the month.

share|improve this answer
add comment

Looks like OpenGL extensions are not installed or functional and that also explains your issue with 3D software. First lets see what kind of graphics card do you have. Type the following command in terminal:

lspci

Look for the line with VGA in it and add that information to your question. My guess is that you have an NVidia card and you have not installed the proprietary drivers. Find the Additional Drivers utility and see if any driver is available to install. If yes, installing that should solve your issue.

Edit: Now that I see you have a Silicon Integrated Graphics card, it is clear what the issue is. I think you got somewhat lucky. I just did a quick search on the net and by looking at a blog post and this forum post on the issue, it looks like 3D acceleration was not supported for this chip at all. But from what you describe, it looks like the opensource driver available in 12.04 has got the support. So at this point you have two choices. The obvious choice which you already mentioned is to upgrade to 12.04 which isnt a bad thing specially if it is a personal laptop, and if you are learning. The other choice is to find the driver thats available for 12.04 and install that on your 11.10 if you really want to stick with the more tested version. Honestly, I think your best bet is to dive into 12.04 and enjoy living on the cutting edge for a couple of months :).

share|improve this answer
    
i do not have drivers available i have tried to install but there isn't for i think sis graphic card.. i have edit my question –  user49523 Mar 8 '12 at 20:48
    
can i send what programs and applications i have installed somewhere to see if there is a bug , with file of synaptic? (i have use ubuntu software center and synaptic to install applications) - that cool also be the problem –  user49523 Mar 8 '12 at 21:02
    
i have reinstall all the system again with all previous applications using synaptic and with update marked –  user49523 Mar 8 '12 at 21:13
    
This is not a bug. Your graphics card manufacturer is just very lazy and have not produced Linux drivers. Look at my updated answer for more information. –  Aras Mar 9 '12 at 3:24
    
i have 2 partions with ubuntu 11.10 and 12.04 .. but now that i have upgrade ubuntu 11.04 2 12.04 i still can't load cheese or stellarium, and stellarium give me this error : This system does not support OpenGL –  user49523 Mar 9 '12 at 15:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.