Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am new to ubuntu, and was installing ubuntu 11.04 from a CD. I booted up the CD and went to the installation process. I got to the step where it asked me to allocate my drive space. The window above with the columns titled mount, drive, etc., was completely empty. I didn't know what to do, so I pressed continue anyway. Another window appeared saying that the root file system was not defined, and that I needed to define it from the partitioning menu, which was blank! I have looked everywhere for the solution, and there is a lot of talk about setting the mount point to "/". I understand that that, but where do I set it! I also have not gone through the same installation windows as everyone else. (My installation process seems to skip the window where you decide to install ubuntu or try it from the CD.)

Please Help!

share|improve this question
    
If you can, install 11.10 instead of 11.04. It probably won't make a difference with the installation problem you're having, but it's later and generally more up-to-date. Now, as for setting the mount point, it's tough to know what you're seeing since it appears to be different than most others, but on the same page where you have partitioning choices, there is usually a drop-down box that gives you a choice for setting the mount point, and one of those choices is "/". –  Kelley Mar 6 '12 at 22:44
    
I tried that, but when there is only one option in the scroll down menu,"/dev/sda". –  Maitreya Mar 7 '12 at 0:43

2 Answers 2

Some RAID code was interfering with the installation. I opened a terminal and entered

sudo apt-get remove dmraid

After I entered it, I tried the installation again, and it worked. I was able to select my partition and run it along with windows.

share|improve this answer
1  
Actually, I eventually replaced Windows Vista with it. –  Maitreya Mar 17 '12 at 18:47

Sounds like it couldn't read your hard disk. Press Ctrl+Alt+F2/F3/F4, find the debug output, and look for errors.

Using a newer version of Ubuntu may also solve it.

share|improve this answer
    
Those commands don't do anything for some reason. Alt+F2 opens a window letting you run applications, that is it. –  Maitreya Mar 7 '12 at 0:56
    
Oops, I forgot you're in X. Use Ctrl+Alt not just Alt. But really, try the newer version. –  blujay Mar 7 '12 at 1:06
    
It is reading my hard disk as "/dev/sda1". But in the installation menu, I can't select that from the table. –  Maitreya Mar 7 '12 at 1:15
    
You need to look for errors relating to the partitioner. But really, try the newer version before wasting a lot of time on this. –  blujay Mar 7 '12 at 5:53
    
I tried the newer version before, using wubi, and from a flash drive that I created. I kept getting the same errors that I'm geting now. Because I don't have a CD burner( my drive only reads CDs) I thought that using a later version would be okay, just so that I could use the CD installation. I only have the CD for Ubuntu 11.04, it's a Linux format DVD. –  Maitreya Mar 7 '12 at 23:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.