Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu 11.10 (oneiric ocelot):
When I try to add a new ppa through add-apt-repository, it returns with:

rene@rene-MS-N104:~$ sudo add-apt-repository ppa:tualatrix/ppa
Traceback (most recent call last):
  File "/usr/bin/add-apt-repository", line 88, in <module>
    ppa info = get_ppa_info_from_lp(usr, ppa_name)
  File "/usr/lib/python2.7/dist-packages/softwareproperties/ppa.py", line 80, in get_ppa_info_from_lp
    curl.perform()
pycurl.error(35, 'gnutls_handshake() failed: A TLS packet with unexpected length was recieved.')

I'm fairly new to Ubuntu and am not sure how to proceed.

share|improve this question
add comment

4 Answers

up vote 7 down vote accepted

It appears this is a known issue/bug, you could try this workaround:

To install PPA's, add them to /etc/apt/sources.list in the form:

Before:

ppa:<user>/<repo>

Add to sources.list:

deb http://ppa.launchpad.net/<user>/<repo>/ubuntu oneiric main

Then sudo apt-get update and download whatever packages you want.

share|improve this answer
    
Is there any system way to solve this question? Thank you~ –  sam Oct 13 '12 at 9:50
    
You will have to upgrade to 12.10 –  LnxSlck Oct 13 '12 at 11:12
add comment

I had the same problem when I was using the WiFi. But then I tried with my mobile broadband connection which uses automatic PPP and it worked fine. I am not sure but it may be to do with opening of port 11371 in the router of WiFi.

share|improve this answer
add comment

In my case,and that worked, that's what I did in Ubuntu 12.04:

sudo apt-get clean
sudo apt-get update

And then I tried to add my ppa as usual :

sudo add-apt-repository ppa:.../...

Hopes it works for everyone !

share|improve this answer
add comment

Please refer to the following URL for the solution.

http://old.nabble.com/Big-CA-certificate-bundle-causes-problems-with-GnuTLS-3.0.11-td33925560.html

Quoted from one of the comments in the link.

A quick solution to avoid this issue is to restrict the CAs that you enable to the server to the minimum required (a typical server needs to trust only the authorities that signed the user's certificates).

share|improve this answer
3  
Linking external sites as an answer is never recommended, preferably you should copy the important information that you think might be helpful and leave a link to the source. One link answers are not good answers. –  Bruno Pereira Jun 9 '12 at 9:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.