Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am new to Ubuntu and I have just installed Ubuntu 11.10. The problem is that the BCM4313 wireless card keeps disconnecting all the time.

From the Additional drivers window, I can see that the "Broadcom STA wireless driver" is installed.

I would appreciate any help at the moment as I am thinking to return back to Windows.

The output of "lsmod | grep cfg80211" is cfg80211 199630 2 brcmsmac,mac80211

share|improve this question
    
Could you paste the output of lsmod | grep cfg80211 ? –  sagarchalise Mar 6 '12 at 17:14
    
possible duplicate of Broadcom BCM4313 working, but terribly slow –  Jorge Castro Mar 6 '12 at 17:24
    
cfg80211 199630 2 brcmsmac,mac80211 –  Elshaer Mar 6 '12 at 17:30
add comment

1 Answer 1

up vote 0 down vote accepted

There are two drivers for this chip AFAIK.

Try lsmod | grep cfg80211 and see if it outputs wl or brcmsmac.

brcmsmac

This is open-source driver which comes in the kernel so it should work out of the box. But in some case you may need to blacklist bcma module first. If you are not using it by default in order to give it a try do

sudo modprobe -r wl && sudo modprobe brcmsmac

OR if the above command doesnot give you anything

sudo modprobe -r bcma ssb wl && sudo modprobe brcmsmac

wl

This is the additional driver you are talking about provided by the package broadcom-sta-common. You can test it the same way as above just do.

sudo modprobe -r brcmsmac bcma b43 && sudo modprobe wl

The opensourcedriver doesnot have a LED support so your wireless LED won't turn on. Apart from that the open source driver doesnot have powersave option as well which is enabled during battery laptop usage. But my internet connection lagged during powersave option of wl driver.

If you find your internet connection lagging during battery try How can I prevent iwconfig power management from being turned on?

See which works for you.

In order to make things permanent just add

blacklist MODULE_NAME in /etc/modprobe.d/blacklist.conf and inorder to load the module add it in /etc/modules. So if you would like to use say wl you would add

blacklist brcmsmac
blacklist bcma
blacklist ssb
blacklist b43

in /etc/modprobe.d/blacklist.conf and add wl in /etc/modules

This is a pretty good documentation on broadcom drivers.

share|improve this answer
    
Thanks a lot, but after trying both commands for brcmsmac still nothing happens :( –  Elshaer Mar 6 '12 at 18:29
    
Did you try wl one as well ? Try permanent solutions. –  sagarchalise Mar 7 '12 at 3:01
    
No i just tried the brcmsmac because the output of "lsmod | grep cfg80211" is brcmsmac. –  Elshaer Mar 7 '12 at 19:47
    
Should i try the wl ? –  Elshaer Mar 7 '12 at 19:47
    
Well the output says what driver you are using, and your are using opensource driver by default not additional driver. If one doesnot solve your problem you should certainly try the next. –  sagarchalise Mar 8 '12 at 5:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.