Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Having installed HPLIP on my 10.10 system, the HP Photosmart 420 gives "Device Communication Error" code 5012 when I try to print. Running hp-check lists 11 missing dependencies. Do I have to install them all one by one or is there an easier way to get the printer going? What is the command to install a dependency?

share|improve this question
    
On a side note, your system should have all required dependencies for hplip already installed if you installed it from the Ubuntu repos through the package management tool of your choice. Or did you install it from elsewhere? –  Christopher Kyle Horton Mar 6 '12 at 16:51

4 Answers 4

up vote 4 down vote accepted

In terminal

sudo apt-get -f install hplip

should fix it

There is the other option here : source

which has the download and installation instructions. It has a section that will run

DEPENDENCY AND CONFLICT RESOLUTION

This is the direct download source

share|improve this answer
    
I installed hplip as indicated but it still says missing dependancies. When I tried installing the first missing dep. ie "CUPS devel" it could not find said dependancy. –  Rosco Mar 7 '12 at 17:00
    
are you able to give us the print from terminal as to the error message –  Ringtail Mar 7 '12 at 17:04
    
Thanks for the info BlueXrider. When I do that I get this:Could not open the file /home/mystuff/Downloads/hplip-3.12.2.run using the Unicode (UTF-8) character encoding.Which char encoding do I need? –  Rosco Mar 9 '12 at 12:17
    
this is the web site hplipopensource.com/hplip-web/index.html follow the instructions at the left of it. Where it says Install and Setup –  Ringtail Mar 9 '12 at 12:56
    
Thanks BlueXrider. Did that and fixed all dependancies. Rebooted PC.But still get this:Type: Printer Device URI: hp:/usb/Photosmart_420_series?serial=CN59N250BX04HP PPD: /etc/cups/ppd/Photosmart_420.ppd PPD Description: HP Photosmart 420 Series, hpcups 3.10.6 Printer status: printer Photosmart_420 is idle. enabled since Fri 09 Mar 2012 17:30:26 GMT error: Unable to communicate with device (code=12): hp:/usb/Photosmart_420_series?serial=CN59N250BX04HP error: Device not found error: Communication status: Failed –  Rosco Mar 9 '12 at 17:38

If you know what the needed packages are, you can simply run the usual sudo apt-get install in a terminal, followed by the names of the packages required.

share|improve this answer

The dependencies can be installed following instructions here: http://hplipopensource.com/hplip-web/install/manual/distros/ubuntu.html

hplip is not a dependency, it's the package that contains hp-check and other utilities. The dependencies such as "CUPS devel", "Python devel", "PyQt4" and so on can be installed using the following command for Ubuntu 10.04 and up, according to current info from link above (but I recommend checking for updated info):

sudo apt-get install --assume-yes libcups2 cups libcups2-dev cups-bsd cups-client libcupsimage2-dev libdbus-1-dev build-essential ghostscript openssl libjpeg62-dev libsnmp-dev libtool libusb-dev python-imaging policykit-1 policykit-1-gnome python-qt4 python-qt4-dbus python-dbus python-gobject python-dev python-notify python python-reportlab libsane libsane-dev sane-utils xsane
share|improve this answer

I also had this problem. The way for this to work is to install the hplip toolbox from the software center. Then sudo hp-toolbox and then you should be able to install the correct plugin. In fact if you type hp- then tab you should see a bunch of for HP printers.

share|improve this answer
    
-1 just tried this and get warning: hp-toolbox should not be run as root/superuser, followed immediately by error: dBus initialization error. Exiting. –  Tom Brossman Feb 2 '13 at 14:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.