Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can I install emacs on Xubuntu , the command:

sudo apt-get install emacs

doesn't work

share|improve this question
1  
to clarify sudo apt-get install emacs does what? what terminal output do you see? Which version of xubuntu are you using? –  fossfreedom Mar 6 '12 at 12:57
    
It doesn't appear if i write sudo apt-get install e and then with tab there is no emacs –  0x90 Mar 6 '12 at 12:58
    
Try pressing tab twice in rapid succession. It will ask you something like "Display all 564 possibilities? (y or n)". Try writing 'sudo apt-get install emac' and then press tab. –  bessman Mar 6 '12 at 13:13
    
didn't work, never mind switched to UBUNTU –  0x90 Mar 6 '12 at 13:18
    
Apparently you did not have tab completion enabled for apt-get. You should be able to fix that with sudo apt-get install bash-completion. –  tripleee Jan 23 '13 at 8:40

3 Answers 3

up vote 6 down vote accepted

One way to find out is navigate to the following URL in a browser:

http://packages.ubuntu.com/

try your search there, of course you will need to select the appropriate version your using. This should give you a brief answer if the package is included for your version of ubuntu.

Another easy way is to search on your local system if emacs is available in the PPA

  • Open a command line terminal by issuing Ctrl-Alt-T or searching for terminal in the Dash and type

             #sudo apt-get update
             #apt-cache search emacs
    

This will search all of the packages in the ppa for the words emacs in the title.

According to my response theres a few packages available.

emacs - The GNU Emacs editor (metapackage)
emacs-goodies-el - Miscellaneous add-ons for Emacs
emacs23 - The GNU Emacs editor (with GTK+ user interface)
emacs23-bin-common - The GNU Emacs editor's shared, architecture dependent files
emacs23-common - The GNU Emacs editor's shared, architecture independent infrastructure
emacs23-el - GNU Emacs LISP (.el) files
emacs23-nox - The GNU Emacs editor (without X support)

So essentially you could try to

#sudo apt-get install   

any of the above packages.

share|improve this answer
    
I like to use aptitude to search for packages, although it will get you pretty much the same result. –  cg505 Feb 9 at 18:45
sudo apt-get install emacs

should do the trick.

share|improve this answer

Xubuntu includes the Synaptic Package Manager by default. Please go to the menu, System, Synaptic Package Manager, and search on EMACS. It will guide you to the correct applications.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.