Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

If I reboot the router (Netgear DGN2200) my Ubuntu 11.10 Server box does not reconnect to the network. This is over a wired link either with a reserved IP Address over DHCP or a static IP Address configuration in /etc/network/interfaces as:

# The loopback network interface

   auto lo
   iface lo inet loopback

# The primary network interface

   auto eth0
   iface eth0 inet static
   address 192.168.1.100
   netmask 255.255.255.0
   broadcast 192.168.1.255
   network 192.168.1.0
   gateway 192.168.1.1

Both connection methods fail after a router reboot i.e. no ping, no ssh, no http. I have never had to do anything special to ensure reconnection before - but am I missing something?

Thanks

S

share|improve this question
    
I have now tried this with two different NIC's and still get the same result, i.e. no reconnection on Router reboot. My testing strategy now is to try a direct wired connection (I am going through a junction box at the moment) and then swap out the router for another. If still no luck I guess this may be something deeper. Again if anyone has any ideas let m eknow. –  siloko Mar 7 '12 at 15:43

1 Answer 1

you could try adding the following before auto eth0 line in the interfaces file;

allow-hotplug eth0

this should start the interface eth0 when th kernel detects a hotplug event from teh interface.

ifdown eth0 #this drops the eth0 interface NB: if SSH'd etc.. it will kill your connection ifup eth0 # brings the connection back..

i'd set a continous ping from another machine to the server... bounce the router and see what happens. you many need to restart the server for the "allow...." line to take affect. I think the ifup\down does it too.. its been a while.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.