Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I noticed today there is a directory called '~amir` in /. This seems really odd. The same directory is in my /home directory as amir is my username. They directories contain exactly the same data!

Does anyone know how/why this happened and how I remove the one in root? Executing 'rm ~amir" will remove my home folder won't it?

Here is the output from ls with the offending item being the first directory shown:

root@superMassive:/# ls -al
total 96
drwxr-xr-x  25 root root  4096 2012-03-06 03:00 .
drwxr-xr-x  25 root root  4096 2012-03-06 03:00 ..
drwxr-xr-t   3 root root  4096 2012-03-02 02:10 ~amir
drwxr-xr-x   2 root root  4096 2012-02-27 06:51 bin
drwxr-xr-x   3 root root  4096 2012-02-27 06:52 boot
drwxr-xr-x  17 root root  4440 2012-03-06 08:33 dev
drwxr-xr-x 101 root root  4096 2012-03-06 08:33 etc
drwxr-xr-x   4 root root  4096 2012-03-06 09:04 home

And here is the output to mount as requested:

root@superMassive:/# mount
/dev/sda1 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
/dev/md0 on /massiveData type ext4 (rw)
rpc_pipefs on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
nfsd on /proc/fs/nfsd type nfsd (rw)
share|improve this question
    
what's the output of mount? –  Githlar Mar 6 '12 at 9:36
    
There is no amir in mount output. I will add it now to the question. –  Amir Mar 6 '12 at 9:52
add comment

1 Answer 1

I think I must have created this directory by accident when setting up minidlna. I realised that the contents of this directory were in fact not the same as the home directory. When I was comparing them I was actually entering the home directory not the one at root level. I realised when I used the pwd command to see where I was.

In the end I was able to specify the directory at root level by prepending a / - so rm -R /~amir deleted the copy at root level rather than the one in home.

Sorry to have wasted your time.

share|improve this answer
    
It's always nice when people solve their own problems =). Have a nice day! –  Githlar Mar 6 '12 at 11:03
    
Or you could say, 'people should try harder before asking for help' lol :) Anyway - if I find answers I always share. I figure someone else out there must be having the same problem! :) –  Amir Mar 7 '12 at 15:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.