Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently assembled a new computer with the second generation Intel Core i7-2600K processor (Sandy Bridge) and solid state drive. The solid state drive is only 60 GB and I have lots of RAM so I did no create a swap partition. Ubuntu is installed on a GUID partition and I'm using EFI boot if that's relevant. My motherboard is the Asus P8Z68-V LE and I currently have the automatic overclocking feature enabled.

Every thing seems to be working fine with this new system at the moment, except I cannot put it to sleep. If I choose "Suspend" in GNOME 3, the computer shuts off and I have trouble turning it on again. Here's what happens when I try to turn the computer on again after it fails to sleep:

  1. The first time I push the power button to turn it on again, my monitors won't turn on again and the system doesn't do anything. At this point, I hold the power button to turn the computer off again.

  2. The second time I try to turn it on, the UEFI (BIOS) beeps three times and I still don't see anything on the monitors. I have to push and hold the power button again to get it to shut off.

  3. The third time I try and turn the computer on, it works okay.

So far I haven't had any problem shutting the system down or booting it up. Has any one else experienced this problem? Or could anyone point me in the right direction to find a solution?

Thanks!

share|improve this question
add comment

1 Answer

Firstly, thank you for submitting a very detailed and well set-out question.

I have a similar system set-up to you and have had almost the exact same situation occur, regarding suspend-resume for ages now.

I just found a fix which seems to work, detailed in a couple of other places including on this site. Suspend and resume problems seem to be rife in Ubuntu, for some reason.

The solution is simple:

  • Edit the file /etc/default/grub (as root)
  • Change the line with:

    GRUB_CMDLINE_LINUX=""
    

    to:

    GRUB_CMDLINE_LINUX="acpi_sleep=nonvs"
    
  • run update-grub (as root)

As I say; this seems to work for me, so I hope it will work for others, too.

Suspend fails (reboot on resume) and no hibernate option

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.