Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Possible Duplicate:
Alps Loaded but PS/2 mouse also loaded!

I have a Dell Inspiron 15R with Ubuntu 11.10 x86-64 installed. I am having a problem with the Alps touchpad. My touchpad's driver loads, which is synaptics, and it gets recognized in xinput --list and in Xorg.0.log, but it's still not working. In xinput --list I can see two devices loaded at the same bus: "PS/2 Mouse" and "Alps/PS2 ALPS GlidePoint".

Any workaround and any further logs will be provided (if) when requested.

share|improve this question

migrated from Mar 6 '12 at 0:16

This question came from our site for users of Linux, FreeBSD and other Un*x-like operating systems.

marked as duplicate by Jorge Castro, Takkat, jokerdino, Eliah Kagan, Ringtail Sep 16 '12 at 15:51

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

The touchpad support was improved recent kernels, so switching to a newer kernel could help. –  jofel Mar 5 '12 at 23:41
installed kernel 3.3.0 rc5, but still that problem persists, everything is loaded, i mean every driver! –  Ahsan Mar 6 '12 at 3:56

1 Answer 1

I had exact same problem on my Inspiron N5110 running Ubuntu 12.04 but was able to fix it using patch and instructions provided in these two links.

Touchpad is now recognised as a AlpsPS/2 ALPS DualPoint TouchPad and Touchpad tab is enabled in System Settings. Unfortunately, scrolling is still not an option... :-(

At least touchpad is disabled while typing, which was the biggest problem for me resulting in cryptic writings! :-)

[EDIT]: Also Fn+F3 is working now (aka, touchpad toggle).

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.