Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How do I disable loading of unnecessary kernel modules. Kernel 3.2.4

share|improve this question
Related: – Christopher Kyle Horton Mar 5 '12 at 23:47
thanks, must be a dupe – Ringtail Mar 6 '12 at 0:01
up vote 19 down vote accepted

Note: blacklisting will not work for modules which are built into the kernel image (i.e. not loaded via a separate .ko file. The only way to disable such modules is via a kernel parameter (if available) or by recompiling the kernel.

Just open your /etc/modprobe.d/blacklist file and add drivername using following syntax:

blacklist driver-name

EDIT: In later versions since 12.10 (12.04?) the file is /etc/modprobe.d/blacklist.conf

Reboot your box and use lsmod command to show the status of modules in the Linux Kernel

Note: here driver-name is the name of your desired blacklist driver. For example, If you wanted to disable the NIC card driver, you can find the name of kernel driver for your LAN card by using the command lspci -v command in a terminal.
For Example my output was :

6:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5906M Fast Ethernet PCI Express (rev 02)
    Subsystem: Lenovo Device 3861
    Flags: bus master, fast devsel, latency 0, IRQ 46
    Memory at b8000000 (64-bit, non-prefetchable) [size=64K]
    Expansion ROM at  [disabled]
    Kernel driver in use: tg3
    Kernel modules: tg3

Here, I see the driver is tg3. so you need to write tg3(or your driver) in the place of driver-name.

Plenty of info can be found here.

share|improve this answer
in my case (Lubuntu 12.10), there is not a /etc/modprobe.d/blacklist file. There is a /etc/modprobe.d/blacklist.conf file – Abdull Mar 29 '13 at 11:27
Thanks for the info. – LnxSlck Apr 1 '13 at 19:56

You can also temporarily blacklist them on the grub command line (linux line) when you boot with the syntax

share|improve this answer
Seth, it is temporary for just the single boot if you edited during boot. If you edit using /etc/grub.d/ scripts or /etc/default/grub, then it is permanent. – Peter Jul 14 '13 at 11:08
Apparently this does not work for i915: i915: unknown parameter 'blacklist' ignored. – Rafał Cieślak Jul 3 '14 at 15:05
@bodhi.zazen - thanks, but I do not have any problem - I have just noted that this may not work for some particular modules :) – Rafał Cieślak Jul 3 '14 at 17:58
What is the difference between this and modprobe.blacklist=module_to_blacklist? – Zaz Jun 4 '15 at 22:20
or use the kernel parameter modprobe.blacklist=module_to_blacklist (see man modprobe for details) – Karl Richter Jun 13 '15 at 11:29

None of these solutions worked on 16.04 LTS for i915.ko.

The (dirty) solution I found was to rename


Unfortunately, external VGA screen is not recognised anymore :{

share|improve this answer
All you need is sudo update-initramfs -u after modifying /etc/modeprobe.d/ files – Ivan Black Jul 13 at 22:12

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.