Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First I got a error message saying that no init found blah blah on booting up. I thought of clearing it via Disk Utility, doing so results me in File mounted or opened by another program.

I tried even GParted, which doesn't help me. This again results in same problem saying that File mounted or opened by another program.

Notably the disk utility says there are 423 bad sectors in my disk, but the problem is that I couldn't clean or repair it! For example running my SMART self test results in FAILED(READ).

Now I need my Ubuntu back to be running. How I can do that? Am a newbie to Ubuntu and I felt really hard of recovering from this problem.

share|improve this question
    
Have you tried to boot from a live-cd. What are you exactly trying to accomplish?. What is happening?. Please give us more info. It's hard to know what is happening from your question. I removed the rant, feel free to share your opinions in the forums (ubuntuformus.com), but please, this place is just for questions and answers. –  Javier Rivera Mar 5 '12 at 18:15
    
@JavierRivera : Yes I have made all these attempts from a live cd. I need my Ubuntu back to run. –  Ant's Mar 5 '12 at 18:19
    
I tried even a SMART test using Disk Utility, but running so has no effect. After clicking on the Run Self Test I get a FAILED(READ) message . –  Ant's Mar 5 '12 at 18:23
    
You could be experimenting a hardware failure. You should try to connect the drive to another computer to check if it is working. A SMART error is, usually, very bad news. –  Javier Rivera Mar 5 '12 at 18:47
1  
Then use it to recover as much data as possible. It's very unlikely that all the disk is damaged. There are some tools that can help you to recover content, if it is really damaged. But IMHO, the first step is to check that it is really a hardware problem (check in another computer) and if you are sure it is, you should make an image with ddrecover and stop using it (you should use damage recovery tools with the image, whenever possible). If there is a hardware problem, continuous use could damage more the disk, and that could mean more data loss. –  Javier Rivera Mar 6 '12 at 8:30
show 3 more comments

2 Answers 2

up vote 1 down vote accepted

I found a solution to my problem, I used Ubuntu 10.04 Live cd, which resulted me in error while repairing the disk stating that :

File mounted or opened by another program.

But I downloaded Ubuntu 11.04 iso file and booted it from my USB. And done these steps :

1)Opened up Gparted, selected my disk which has a bad sectors (which can be found from Disk Utility Tool), and did a check on it by Partition -> Check.

2)After that go to Edit -> Apply all operation, click on the confirmation message that appears.

It will take some time and all the errors have been cleared and now my Ubuntu is recovered.

share|improve this answer
add comment

As @Javier Rivera points out, you are most certainly experiencing a hardware failure.

Bad sectors on a HDD means that your affected partition can't be accessed without repairing the sectors. If the bad sectors previously contained data, it's even harder for a recovery tool to repair the damage.

The fact that S.M.A.R.T. has failed to diagnose the disk means that there might be even more problems then the bad sectors.

I know it's not what you were hoping to hear, but I am certain your HDD is gone, with the data on it as well. I really hope you have a back-up on a different disk. As a last resort you can take your disk to a specialized IT shop (there are shops who do diagnose on hardware components as well) and they may try to recover the data.

Good luck.

P.S. Some literature: Bad Sectors and S.M.A.R.T.

share|improve this answer
    
But I'm surprised that, I used Ext2Read and it cleanly shows my contents of my hard disk i.e Ubuntu partitions. –  Ant's Mar 6 '12 at 0:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.