Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My skype is crashing silently. I tried to follow advice here:

What to do when Skype freezes silently?

and here:

http://ubuntuforums.org/showthread.php?p=11653257

But it suggests giving permission to a file called libpulsecore-1.0.so

I looked in /usr/lib/ and it wasn't there.

I tried sudo apt-cache search libpulsecore-1.0.so and found nothing.

The tab-autocomplete after typing libpuls also didn't return anything, so I believe it is not installed.

I found nothing with which libpulsecore-1.0.so and had no google hits for how to find the file, or which package it was in.

How do I install this file? Sound otherwise works. (Skype even used to work fine until a couple of weeks ago.)

I'm running 11.10.

share|improve this question
    
You don't say what version you're running... –  hbdgaf Mar 5 '12 at 17:37
    
I'm running Oneiric. –  Mittenchops Mar 5 '12 at 17:39
add comment

1 Answer 1

up vote 1 down vote accepted

"looked in /usr/lib/ and it wasn't there."
okay...

"I tried sudo apt-cache search libpulsecore-1.0.so and found nothing."

apt-cache search runs as non-root just fine.
It flags mostly on words in the description and words in the package name

"which libpulsecore-1.0.so"

which is for binaries you run from the CLI
to show 'which' will be executed first with your path settings

to find out if you have it:

sudo updatedb && locate libpulsecore | grep '.so'

to find out what provides it:

dpkg -S libpulsecore

Looks like the base pulseaudio package on 11.10 which is what I'm running for production until 12.04 goes stable in about a month.

sudo apt-get install pulseaudio

Done.
EDIT:
if it says you have pulseaudio but you don't have the .so you need a --reinstall switch on the apt-get line

share|improve this answer
    
Yep, good point. I had poor diagnostics and was looking incorrectly---it was there the whole time. Thanks! –  Mittenchops Mar 5 '12 at 18:12
    
not a problem...you'll notice I didn't put the version number in the searches. this is in case it changes from 1.0 to 2.0 or whatever so you can still find it if there's a version change –  hbdgaf Mar 6 '12 at 1:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.