Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How can I install atheros drivers to my Toshiba laptop (64bit), manually?

I need AR9285 wireless adapter, and AR8152(v1.1) wired, fast ethernet.

I cannot connect my UberStudent1.0 (linux OS, Ubuntu10.04,equiv.) to the net. I have on the laptop Mint8 which connects well and able to download any drivers. Please, would you kindly show me how to install them if they are not .deb formats. Tarballs, zip,etc, still give me a hard time to work with.

share|improve this question
up vote 2 down vote accepted

You might need to install additional wireless drivers, this can be difficult without a network connection.

I recommend downloading the AMD64 .deb directly from this page and then copy them onto a USB key or CD-R and back onto your laptop. Then install it by double clicking on it and following the instructions in the Software Center, then you'll probably need to reboot. Your wireless card should work at that point.

After that install linux-backports-modules-wireless-maverick-generic Install linux-backports-modules-wireless-maverick-generic so that you'll have that package installed so you'll get upgrades.

share|improve this answer
Thanks. I'll let you know after I tried. – Dave A Nov 3 '10 at 1:35
Man, you aaaaaaare(!) a gen1us! It worked perfectly in no time. Even though I had to burn the files into a dvd+rw because even the usb stick was not recognisable (i,e it had no drivers installed). You saved me lots of time. I have been trying this for days. You deserve a medal! Thanks a lot again. God Bless you! – Dave A Nov 3 '10 at 2:21
SOOO SOLVED!!! THANKS GUYS! – Dave A Nov 3 '10 at 2:27
excuse me, but my software center doesn't seem to be able to download AMD64.deb why is that? is there another way to download it? – user10547 Feb 10 '11 at 3:55

check this for wireless driver! I had the same problem before and I've found the solution!
for install drivers you can simply go to System > Administration > Additional Drivers, ubuntu will detect drivers you need

share|improve this answer
This doesn't work with my laptop. That place is completely empty, even with my Mint8 which connects to the net. – Dave A Nov 3 '10 at 1:34

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.