Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just setup ubuntu 11.10 on Dell XPS 15z by following the instruction from here:

Current status/known issues for DELL XPS 15z?

Everything seems ok until the point I failed to run openGL on chrome:

This is the step I follow to setup the machine:

1) Add bumblebee ppa

2) install nvida-current from restricted drivers

3) install bumblebee (remember to "sudo usermod -a -G bumblebee YOURUSERNAME" as said by the bumblebee readme)

4) install mesa-utils

5) reboot

6) try intel card with terminal command "glxspheres"

7) try nvidia card with terminal command "optirun glxspheres"

While the step 7 is success, but step 6 was failed with following error message:

Xlib: extension "GLX" missing on display ":0".

When I run "glxinfo|grep OpenGL", it prompts

"Xlib: extension "GLX" missing on display ":0"."

This is my /etc/X11/xorg.conf

Section "Device"

    Identifier      "Default Device"

    Option  "NoLogo"        "True"


I have turned on webgl support for chrome as well.

Fairly new to this, how could I fixed this?

share|improve this question
I fixed that after following instruction with…. I got both Intel & Nvidia Graphic Card working. Problem now is chrome still couldn't run webGL, but firefox can. – TonyMocha Mar 5 '12 at 10:27

As the title does not mention NVidia, (and for those who can run WebGL on Firefox but can't on Chrome) another option is to try enable Override rendering software list in


Hope it helps

share|improve this answer
Exactly what I was after! – nedned Nov 18 '12 at 12:00
Thank you. WebGL used to work for me if I used optirun google-chrome to launch it. Then after an update it stopped working and I noticed HTML <video> was jerky. I tried a few times to fix it and almost contemplated switching to Firefox. Your answer saved the day. – Andy E Feb 21 '13 at 14:13
Works for me. Ubuntu 12.04.2 LTS [GeForce GT 630M] – Peter Johnson Mar 27 '13 at 12:50
up vote 3 down vote accepted

Successfully have it running with both intel and nvidia graphics running by following instruction from here:

Did a test on glxinfo | grep OpenGL and optirun | grep OpenGL, both working.

Eventually the webgl issue for chrome is by misconfiguring the chrome://flags, reset it and everything is fine.

share|improve this answer

I had a very similar problem. Try starting Chrome with this command google-chrome --ignore-gpu-blacklist. Home this helps.

share|improve this answer

I had the same issue. After installing Bumblebee drivers is used:

    optirun /opt/google/chrome/google-chrome --ignore-gpu-blacklist %U

It works like a charm!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.