Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I met this error while updating.I read questions and answers about this problem , but the point is signing key. It doesn't return signing key!

Get:1 http://archive.canonical.com lucid Release.gpg [198B]
Ign http://archive.canonical.com/ lucid/partner Translation-en_US
                ...
                ...
                ...  
Get:24 http://archive.ubuntu.com lucid-security/main Packages [380kB]          
Get:25 http://archive.ubuntu.com lucid-security/restricted Packages [14B]      
Get:26 http://archive.ubuntu.com lucid-security/multiverse Packages [4,556B]   
Get:27 http://archive.ubuntu.com lucid-security/main Sources [118kB]           
Get:28 http://archive.ubuntu.com lucid-security/restricted Sources [14B]       
Get:29 http://archive.ubuntu.com lucid-security/universe Packages [125kB]      
Get:30 http://archive.ubuntu.com lucid-security/universe Sources [34.5kB]      
Fetched 12.8MB in 10min 33s (20.3kB/s)                                         
Reading package lists... Done
W: GPG error: http://archive.canonical.com lucid Release: Unknown error executing gpgv
W: GPG error: http://archive.ubuntu.com lucid Release: Unknown error executing gpgv
W: GPG error: http://archive.ubuntu.com lucid-updates Release: Unknown error executing gpgv
W: GPG error: http://archive.ubuntu.com lucid-security Release: Unknown error executing gpgv
share|improve this question
1  
similar question today - possibly server issues? askubuntu.com/questions/110215/… –  fossfreedom Mar 5 '12 at 15:00
    
@guntbert: What should i have to do if i have an lucid lts Version ? regards John –  user1755592 Oct 28 '13 at 9:04

3 Answers 3

up vote 2 down vote accepted

Finally , fixed .

I searched in /lib and found an other "libreadline.so.6" and replaced it and problem fixed.

Thank you for your attention.

share|improve this answer
    
A similar situation to the problem you experienced has arisen in this question, but I'm having trouble understanding how to apply this solution. Where exactly was the file that you replaced, and where exactly was the file you replaced it with? Thanks for any more details you can provide. –  Eliah Kagan Dec 27 '12 at 3:50

Try sudo apt-get clean and then run the update command again.

share|improve this answer
    
I tried sudo apt-get clean and then run the update command again ,but it doesn't changed .When I enter "gpg" in terminal , it returns:"gpg: symbol lookup error: /usr/local lib/libreadline.so.6: undefined symbol: PC".!? –  Mohammad Mar 7 '12 at 12:50
    
It happened when I installed readline6.2.2 for python2.7.2!! –  Mohammad Mar 7 '12 at 13:01
    
Try this:sudo apt-get clean cd /var/lib/apt sudo mv lists lists.old sudo mkdir -p lists/partial sudo apt-get clean sudo apt-get update –  LnxSlck Mar 9 '12 at 1:01
    
No change...!!? –  Mohammad Mar 10 '12 at 3:03

well... same problem here (ubuntu 12.04 , 64bit). This worked for me:

sudo mv /usr/local/lib/libreadline.so.6 /usr/local/lib/libreadline_problem.so.6
sudo mv /usr/local/lib/libreadline.so.6.2 /usr/local/lib/libreadline_problem.so.6.2

sudo ln -s /lib/x86_64-linux-gnu/libreadline.so.6 /usr/local/lib/libreadline.so.6
sudo ln -s /lib/x86_64-linux-gnu/libreadline.so.6.2 /usr/local/lib/libreadline.so.6.2

sudo  apt-get update

:)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.