Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using USB 3G Dongle for Internet. Previously I was using Tata Docomo (India) as provider, and the Internet was working fine. Now I've changed to BSNL, but I'm unable to connect to the Internet on Ubuntu. However, I've checked access point settings and other configuration which are required for BSNL, and it is working fine with same Dongle on Windows 7. Also, I'm able to connect Internet with other providers on Ubuntu, but problem persists only with Ubuntu. The access point for BSNL in my region is bsnlnet. In fact I configure the Dongle with BSNL using default Network Configuration wizard that pops up when USB Dongle is attached.

When Dongle is attached and configured with BSNL, I can see network strength in Messaging menu, in Mobile Broadband category, of Ubuntu (note: my network icon still shows "not connected" status). And when I try to use the connection that I've created, it fails to connect. So far, I tried using Sakis3g script that I came up with while wandering over this issue on other forums, it didn't worked either. I also made sure that there are no special configuration made for BSNL on my Windows 7 installation, and still it is working fine there, the problem is only with Ubuntu.

How can I fix it?

Update:

While I was unable to fix the issue in Ubuntu 11.10, it still exists in 12.04 too. I hope someone finds a solution and posts it, as I want to become full time Ubuntu user but only way to connect internet in Ubuntu for now is to use other provider.

And I bet the problem has something to do with providers network band-type. Since both Tata Docomo and BSNL operate on different GSM band, while in Windows, Huawei Mobile partner manages this and I can use any GSM provider to connect with Internet, I guess this is not happening with Ubuntu, and I can only use Tata Docomo and other providers which operate on same band.

share|improve this question
    
Try bsnllive as access point –  Tachyons Apr 12 '12 at 11:27
    
@I'mnotthisperson: Tried that too, doesn't work. Though it connects in Windows, but I want to get rid of Windows ;-) –  Kush May 3 '12 at 11:13

4 Answers 4

Take a look at this unofficial guide about "How To Setup Mobile Broadband Like BSNL 3G USB DataCard On Ubuntu 11.10".

Besides, according to this answer, there is a bug concerning two USB dongles, Huawei E220 and E1550, on Ubuntu 11.10. The workaround suggested in the thread of the bug is:

  1. Plug your usb dongle;
  2. execute in terminal: sudo usb_modeswitch -v 0x12d1 -p 1003 -V 0x12d1 -P 1003 -R
  3. Then unplug and replug the dongle, and now it will connect.

Hope it helps and don't forget to mark the bug as affecting you, in order to solve it as soon as possible.

If you are still not able to connect to the internet, you can try the solution proposed in this similar question.

share|improve this answer
    
All the steps mentioned in your given link are performed with only access point different due to my different region. But not working, as soon as I try to connect, it notifies that Network is Disconnected, in-spite I can see signal strength in Messaging menu. And same dongle with same provider is working fine under Windows. –  Kush Mar 5 '12 at 16:37
    
Which USB dongle are you using? Huawei, ecc? And if you type lsusb in terminal, you can see it? –  heiko81 Mar 5 '12 at 16:55
    
I'm using Huawei E1550. And I'm can connect to Internet using same Dongle in Ubuntu with different service provider, the problem is only with BSNL, as I mentioned in my question. Also, I made sure there are no special configuration required with BSNL, apart from different Access Point, which every provider have unique to them. –  Kush Mar 6 '12 at 5:59
    
So, maybe I found what is your problem. There is a bug associated with Huawei E220 and E1550 on Ubuntu 11.10. I'm fixing my answer. –  heiko81 Mar 6 '12 at 8:31
    
That command didn't worked, I got following output upon running the above command Looking for target devices ... No devices in target mode or class found Looking for default devices ... No devices in default mode found. Nothing to do. Bye. Even Though I tried by plugging the dongle back in after running the command, but didn't work. I've also followed the bug thread that you mentioned, which suggested using Mobile Partner app that comes with dongle, so using that would be my last option since it doesn't integrates well with network manager. –  Kush Mar 6 '12 at 14:25

I faced issue with HUAWEI E169 & bsnl in past year. It was disconnecting just after it showed it is connected. Do the following hopefully, it solves for you too.

I guess you are an experienced user, please forgive for any error in step 1. (I don't have access to ubuntu right now)

  1. Click on Network manger, click on Edit Settings. Then go to mobile broadband and click to edit your existing bsnl connection.

  2. On the PPP Setting tab choose

    • Authentication: CHAP only untick the rest.
    • Compression: Be sure the following are ticked:
      1. Allow BSD data compression
      2. Allow Deflate data compression
      3. Use TCP header compression
  3. Try to reconnect.

Try other authentication method if the above doesn't work.Only one at a time. BSNL is the only provider having this kind of problem.

share|improve this answer
    
Tried different combinations and individually too, of Authentication methods, but didn't work either, looks like I currently have no option except to use a different provider to work with in Ubuntu. :-( –  Kush May 8 '12 at 10:57
    
give output of lsusb with dongle connected –  Web-E May 8 '12 at 11:18

0 down vote

i use wvdial to connect to my 3g modem as below:

install wvdial : sudo apt-get install wvdial

edit the wvdial.comf file by any text editor say gedit by below command:

sudo gedit /etc/wvdial.conf

copy paste the following lines in wvdial.conf

[Dialer a]

Modem Type = Analog Modem

Phone = *99#

ISDN = 0

Baud = 460800

Username = " "

Password = " "

Modem = /dev/ttyUSB0

Init1 = ATZ

Init2 = at+cgdcont=1,"ip","your apn"

Stupid Mode = 1

4 connect using ,( u can change the name as u want by replacing a in above wvdial.conf )

wvdial a

(just add apn according to isp you are using like aircelgprs for aircel, bsnnet for bsnl etc. in wvial.conf file in place of "your apn")

share|improve this answer

sudo wvdial Defaults --> WvDial: Internet dialer version 1.61 --> Cannot open /dev/ttyUSB0: No such file or directory --> Cannot open /dev/ttyUSB0: No such file or directory --> Cannot open /dev/ttyUSB0: No such file or directory

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.