Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just started using Inkscape in Ubuntu 11.10 and I'm not sure what exactly triggers it, but at some point, the Inkscape viewport becomes unresponsive.

The viewport is still visible. I can still manipulate the window itself: move, resize, open menu items at top. The cursor switches style. But clicking on anything within the viewport has no effect.

I must close the file and restart in order to regain control.

share|improve this question
2  
try open it up via terminal and see what comes up in the terminal screen when it freezes –  bean520 Mar 4 '12 at 21:35
    
I'll try this next time I have a chance to play with it. Thanks for the suggestion. –  klenwell Mar 5 '12 at 6:32
add comment

2 Answers 2

up vote 1 down vote accepted

The problem seems to be related to this bug report: https://bugs.launchpad.net/inkscape/+bug/785701, and the problem seems to be Inkscape trying to access files that are currently unavailable to it (files that may be on network shares or external disks that are currently umounted or disconnected).

Mark Roth's answer on that launchpad page had a good suggestion to run "strace inkscape" from the terminal in order to see what happens when Inkscape freezes. You may find that, rather than restarting the system, you can instead mount the disk with the file Inkscape is having trouble stat-ing then try starting up Inkscape again.

share|improve this answer
    
I haven't had a chance to play with Inkscape since I posted this. I went back to Fireworks on my VM. I'm pretty sure I was accessing files on my hard drive so I don't think that bug was the issue. Nevertheless, I appreciate the response and have selected this. I'll try running strace inkscape if it happens to me again. –  klenwell May 21 '12 at 1:07
add comment

What hardware do you have? Your computer may not have sufficient hardware to run such an advanced resource-intensive program.

share|improve this answer
    
New HP Pavilion. Probably not the issue. Unless it has something to do with the video card. (See askubuntu.com/questions/105651/…) –  klenwell Mar 5 '12 at 6:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.