Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 11.10 on my HP laptop and among some problems, one of which I'm trying to solve is the touchpad problem. It's working, but how can I turn on/off it?

In SUSE Linux Enterprise Desktop (which was preinstalled) and Windows, the touchpad is enabled/disabled by touching the left upper corner, when small diode is situated. In Ubuntu, I touched that area many times, but nothing happened.

Do anybody know how to solve the problem?

share|improve this question
    
I also tried to install SLED drivers from HP site using one guide for that (first I converted rpm to deb and then installed them, but that didn't fix the problem, I just have "Touchpad" in unity, when I'm typing "synaptics" but when I clicked - nothing happened.) –  ScienceSE Mar 5 '12 at 10:06
    
Don't install touchpad-indicator. It will mess up your installation and not add any significant options. –  Luka Ramishvili Apr 3 '12 at 4:25
add comment

3 Answers 3

up vote 3 down vote accepted

Problem is still unsolved.

But if nobody has any thoughts about how to fix that - here is a possible solutions to help those, who can see this topic (guys from russian linux forums helped me).

You can type in your console:

syndaemon -t -i 2 -d 

This means, that your touchpad will be disabled until 2 seconds after your typing will passed.

But there is a way to fix problems with turning off\on your touchpad and with enabling LED works properly... But this way is complicated. You must download this patches http://abhinandh.com/post/4336662463/getting-the-double-tap-on-the-led-to-disable-touchpad One patch is for kernel and one for xorg server. Also you have to change function parameters.

share|improve this answer
1  
Sadly, the link is broken. –  Luka Ramishvili Aug 6 '12 at 6:52
add comment

I was just looking up this same issue for my HP g7. Have you tried the suggestion posted here:

http://askubuntu.com/a/85866/46766

It's not a completely satisfactory solution as it does not re-enable the upper-left corner "diode". But it sounds like it may reduce incidents where brushing the keypad while typing makes a mess of everything.

share|improve this answer
    
Yes, I've tried to do this... Unfortunately it doesn't solve the problem. But either way thanks for help. –  ScienceSE Apr 3 '12 at 12:22
    
Yes, I still encounter the problem, too, though perhaps less frequently. Frustrating. –  klenwell Apr 3 '12 at 13:36
add comment

I've an HP G62 laptop, and I had the same problem. I resolved installing touchpad-indicator, which let you disable and enable the touchpad with a shortcut (for example, I use ctrl+alt+p to do that).

To install it you should follow the same instructions:

sudo add-apt-repository ppa:atareao/atareao
sudo apt-get update && sudo apt-get install touchpad-indicator

It's available both for 11.10 and for 12.04, now.

share|improve this answer
    
Thanks, i disabled by "synclient TouchPadOff=1". The problem is that touchpad is working not so good as in windows... Even if I touched to him with my wrist it(touchpad) moves my cursor, click him etc... In windows touchpad move cursor and do clicks only when I touch him with fingers. –  ScienceSE Mar 17 '12 at 14:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.