Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When my Ubuntu 10.04 PC stopped booting from one day to the next, I assumed that it is a boot loader problem. I managed to boot from a 11.10 live cd and installed a fresh 11.10 next to the old installation. That worked out, and I am able to mount the old partition and access its data without restrictions (so far).

All good - till the first reboot.

The PC starts extremely slow (2min plus), with no visible activity during the boot process:

dmesg

[   13.671431] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[   19.616008] .
[   24.176004] eth1: no IPv6 routers present
[   26.688016] ..............not responding...
[  124.639436] sd 4:0:0:0: [sdc] READ CAPACITY failed
[  124.639439] sd 4:0:0:0: [sdc]  Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[  124.639443] sd 4:0:0:0: [sdc]  Sense Key : Not Ready [current]
[  124.639447] sd 4:0:0:0: [sdc]  Add. Sense: Logical unit is in process of becoming ready
[  126.661923] sd 4:0:0:0: [sdc] Test WP failed, assume Write Enabled
[  128.684411] sd 4:0:0:0: [sdc] Asking for cache data failed
[  128.684451] sd 4:0:0:0: [sdc] Assuming drive cache: write through

(See full output here.)

From googling around I found references to possibly missing udev rules, something I almost completely don't understand.

But as the whole story started with a failing boot loader, I cannot rule out that I have a general problem accessing the hard drive. What irritates me is the fact that the disk seems completely accessible after the boot process completed (SMART dialog / selftest: all good):

self test

I bought the disk about a year ago, did not have any issues with it since then.

Can someone shed light on what is happening and how to resolve it?

Update: Writing this, I recall that booting into the Live-CD took ages too. So I assume that from the very first moment on when the problems occurred, I'm having this (kernel?) issue.

Update2: My pc is a desktop with Intel® Core™2 Quad CPU Q9650 @ 3.00GHz & 8 giga RAM on a Gigabyte EP35C-DS3R main board. Running on Linux since day one of its existence :-)

Update3: (@Githlar) The message actually repeats once. I posted the whole output here.

Update4 Tried to change BIOS to AHCI (RAID / AHCI / disabled, was disabled before) - no change

Update5 Bought a new disk, installed new Ubuntu - same result (same error, different timing). This seems to rule out the disk and bring the mainboard into attention, what do you guys think?

share|improve this question

closed as too localized by Eric Carvalho, Eliah Kagan, Thomas W., Seth, hhlp Mar 16 '13 at 10:12

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Could you post your computer specs, please? –  crackout12 Mar 5 '12 at 7:22
    
Yeah, it looks like you have a non-standard hard drive firmware of some kind or your disk is failing. Really hard to tell. The kernel can't determine the capacity of the drive, can't reliably determine write-protection status, can't access cache? Very weird. Though it looks like it eventually succeeds after making assumptions on everything. I take it this message repeats a lot until it finally gets through? –  Githlar Mar 5 '12 at 8:00
    
It could also be that the disk is just taking forever to spin up. You might be able to check the SMART data using the "Disk Utility" and check the spin-up time on it (In the SMART dialog, look for any red items. Red = bad). That's how I interpret the "Not Ready" Sense Key, but that's not something I know a whole lot about. Yet another consideration is perhaps updating the HDD's firmware? You can usually get these from the manufacturer's website, but it may involve creating a DOS boot floppy/USB stick. –  Githlar Mar 5 '12 at 8:02
    
Please check BIOS settings that your SSD working in AHCI mode, not P-ATA. –  modosansreves Mar 7 '12 at 8:30
    
This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. Thanks! –  Eric Carvalho Mar 16 '13 at 1:15

1 Answer 1

up vote 0 down vote accepted

'Fixed' issues with purchase of a new mainboard. Thanks to everyone who helped.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.